Announcement

Collapse
No announcement yet.

G4 Mac mini Radeon 9200: How to Enable 3d-Acceleration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • G4 Mac mini Radeon 9200: How to Enable 3d-Acceleration

    Hello there,

    I am using Ubuntu 10.10 on my G4 Mac mini. Almost everything worked out of the box and some issued I was able to fix with the help of forum contents, but to enable the hardware acceleration of the Radeon 9200, 32MB I really need your help.

    Thanks to the support in other forums I
    - tried several xorg.conf standards for radeon (http://mac.linux.be/content/xorgconf-files)
    - forced the chipset in the xorg.conf (ChipID 0x514D)
    - tried this http://blog.kosmokaryote.org/2010/05...mini-with.html
    - removed all graphic drivers leaving only the xserver-xorg-video-radeon.

    But still glxinfo tells me that rendering is enabled, but glxgears runs only with 90fps and when I start driconf I get: Screen "0" is not direct rendering capable.

    Would be really thankful if someone could help me with this issue.
    Thanks

    Here my actual xorg.conf:
    Code:
    Section "Module"
      Load         "dri"
      Load         "dbe"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
    EndSection
    
    Section "Monitor"
      Identifier   "Monitor0"
      VendorName   "Monitor Vendor"
      ModelName    "T17-1"
      DisplaySize  340        270
      HorizSync    31.0 - 81.0
      VertRefresh  56.0 - 76.0
      Option      "dpms"
    EndSection
    
    Section "Device"
      Identifier  "Card0"
      Driver      "radeon"
      ChipID      0x514D
      Option      "UseFBDev"        "on"
      Option      "RenderAccel"     "on"
      Option      "AGPFastWrite"    "on"
      Option      "EnablePageFlip"  "on"
      Option      "AGPMode"         "4"
    EndSection
    
    Section "Screen"
      Identifier "Screen0"
      Device     "Card0"
      Monitor    "Monitor0"
      DefaultDepth     24
        SubSection "Display"
          Viewport   0 0
          Depth      24
          Virtual    1280 1024
        EndSubSection
    EndSection
    
    Section "DRI"
      Group           "video"
      Mode            0660
    EndSection

  • #2
    Pastebin your xorg log and dmesg, or better yet, file a bug:
    https://bugs.freedesktop.org and attach your xorg log and dmesg.

    Comment


    • #3
      Originally posted by agd5f View Post
      Pastebin your xorg log and dmesg, or better yet, file a bug:
      https://bugs.freedesktop.org and attach your xorg log and dmesg.
      http://bugs.freedesktop.org/show_bug.cgi?id=31298

      Thank you for your help

      Comment


      • #4
        On bugs.freedesktop.org I was told that my problem was due to the incompatibility between radeonfs and KMS, both activated.
        After disabling KMS adding radeon.modeset=0 to the kernel-options the 3d acceleration was enabled.
        Glxgears had now 10 times more fps...

        ...but after some testing, I recognize that 3d acceleration may be enabled but is broken.
        If I activate visual effets for the gnome session, I got strange colours but no visual effects. Same for 3d-accelerated games which go really slow.

        In dmesg I get: radeonfb invalid ROM contents.

        I found a similar bug and for them worked adding Option "BusType" "PCI" to the xorg.conf ... but for me it changed nothing.

        You can find the complete dmesg and var.log on On bugs.freedesktop.org

        Thank you for your help

        Comment


        • #5
          Probably endian bugs in the 3D driver.

          Comment


          • #6
            If it is an endianness bug, will it impact PPC64 on a G5?

            Comment


            • #7
              Can I do anything about it?

              Comment

              Working...
              X