Announcement

Collapse
No announcement yet.

How to disable underscan when using kms?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by droidhacker View Post
    Note: Everybody who has this problem should create a bug report at somewhere that will be read, like kernel or freedesktop.
    https://bugs.freedesktop.org/show_bug.cgi?id=32450

    I have

    xrandr --output HDMI-0 --set underscan off

    in /usr/share/config/kdm/Xsetup

    but I don't see that as a good long-term solution. I believe that forcing underscan on everybody is a bad design decision and I firmly reject their tyrannic Underscan World Order.

    Comment


    • #32
      Originally posted by droidhacker View Post
      At least you can recompile your kernel with all instances of "UNDERSCAN_AUTO" replaced with "UNDERSCAN_OFF".... but that IS a REAL PAIN.


      Broken, broken, broken....
      I'm on 2.6.35.9 kernel and I could not find any lines with UNDERSCAN_AUTO or _OFF. Do you know how to remove underscan from this kernel source? (I was able to do that with 2.6.37-rc6 but I prefer 2.6.35.9 for fglrx compatibility).

      Thanks.

      Comment


      • #33
        Originally posted by ntt2010 View Post
        I'm on 2.6.35.9 kernel and I could not find any lines with UNDERSCAN_AUTO or _OFF. Do you know how to remove underscan from this kernel source? (I was able to do that with 2.6.37-rc6 but I prefer 2.6.35.9 for fglrx compatibility).
        The underscan feature wasn't added until 2.6.36.

        Comment


        • #34
          If you're using fglrx, then you need to turn KMS off in the first place, don't you? In which case none of this is affecting you AFAIK

          Comment


          • #35
            Hmm. Thanks for the reply.

            I recently move backward from r600g+2.6.37-rc6+UNDERSCAN_OFF to fglrx+2.6.35. I got underscan problem with the later config and I don't know how to disable it. the xrandr solution is not possible in my case since I don't use X.

            Comment


            • #36
              if you don't use X, why do you need fglrx?

              Comment


              • #37
                Originally posted by jeremyj View Post
                if you don't use X, why do you need fglrx?
                Sorry I misspoke. I meant I don't use any of the gdm/kdm/xdm login manager. It's for my HTPC box. I use mingetty+bash_profile+xinitrc to boot into X and XBMC. Unfortunately, xrandr --underscan=off command would exit X (and quit XBMC), so I could not use it.

                Comment


                • #38
                  using xrandr does not end your X session. You can add the line xrandr --underscan=off to your .xinitrc

                  Comment


                  • #39
                    Man, fglrx is buggy (tearing and random TV signal disconnect). I switched back to r600g and felt much better. The higher speed that fglrx provides isn't worth the setup hassle and the bugs.

                    Comment

                    Working...
                    X