Announcement

Collapse
No announcement yet.

ATI R600 Gallium3D Driver Continues Advancing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • my results with 2d color tiling enabled:

    ioq3, 1680x1050

    192,6 fps - r600g

    183,2 fps - r600c

    Comment


    • I just tried r600c and r600g with Ubuntu Maverick and xorg-edgers packages. I'm amazed to see that compiz and openarena actually works.

      However, in games like openarena I was not able to move the mouse when running r600g or r600c. Any idea what I can do about it? Or is this in no way driver related?

      Comment


      • Originally posted by fiete View Post
        I just tried r600c and r600g with Ubuntu Maverick and xorg-edgers packages. I'm amazed to see that compiz and openarena actually works.

        However, in games like openarena I was not able to move the mouse when running r600g or r600c. Any idea what I can do about it? Or is this in no way driver related?
        same problem with mouse after latest xorg update!

        Comment


        • same problem with mouse here

          Comment


          • No problem here on Gentoo.

            Comment


            • Has anyone tried running Celestia?
              http://www.shatters.net/celestia/

              Comment


              • Originally posted by netkas View Post
                same problem with mouse here
                I think the problem in this package:
                xorg-x11-driver-input

                From YaST2 Change log:
                xf86-input-mouse 1.6.0
                * This update to the mouse driver used mainly on non-Linux
                systems adds Xorg 1.9 ABI support to the Solaris-specific
                code, Genius NetScroll+ serial autodetection, and a number
                of minor bug fixes and a large number of cleanups &
                configuration improvements.

                I think they clean to much.

                P.S. I'm using openSUSE 11.3 + KDE 4.5.2 + R300 (Gallium)

                Comment


                • Yes - it worked fine the last time I tested it.

                  Originally posted by plonoma View Post
                  Has anyone tried running Celestia?
                  http://www.shatters.net/celestia/
                  I tested celestia with Mesa-git a few days ago and it was running beautifully with the OpenGL 2.0 renderer. (This was with my RV790.)

                  Comment


                  • Originally posted by 69acid69 View Post
                    xf86-input-mouse 1.6.0
                    What about using evdev instead?
                    ## VGA ##
                    AMD: X1950XTX, HD3870, HD5870
                    Intel: GMA45, HD3000 (Core i5 2500K)

                    Comment


                    • Originally posted by fiete View Post
                      I just tried r600c and r600g with Ubuntu Maverick and xorg-edgers packages. I'm amazed to see that compiz and openarena actually works.

                      However, in games like openarena I was not able to move the mouse when running r600g or r600c. Any idea what I can do about it? Or is this in no way driver related?
                      There is a problem in xserver master and 1.9rcX see -

                      https://bugs.freedesktop.org/show_bug.cgi?id=30267

                      Comment


                      • R600g finally works well on my RV670. Kwin's 4.5.2 desktop effects now work (but blur does not work with both R600c and R600g) and I have similar performances in openarena (93 fps for R600c and 90 fps for R600g, Very High Quality at 2560x1600)
                        ## VGA ##
                        AMD: X1950XTX, HD3870, HD5870
                        Intel: GMA45, HD3000 (Core i5 2500K)

                        Comment


                        • Originally posted by fiete View Post
                          I just tried r600c and r600g with Ubuntu Maverick and xorg-edgers packages. I'm amazed to see that compiz and openarena actually works.

                          However, in games like openarena I was not able to move the mouse when running r600g or r600c. Any idea what I can do about it? Or is this in no way driver related?
                          How exactly does one go about loading and installing (just) the r600c and r600g drivers from xorg-edgers in Maverick?

                          I am hesitant to add the entire ppa to my repository list in case it over-writes everything in the Xorg stack and hoses my graphics install.

                          Comment


                          • 1 - add xorg-edgers ppa
                            2 - delete /usr/lib/dri/r600_dri.so
                            3 - go to /usr/lib/dri/galium, create link to r600_dri.so and copy it to /usr/lib/dri/
                            4 - restart

                            Comment


                            • Originally posted by icek View Post
                              1 - add xorg-edgers ppa
                              2 - delete /usr/lib/dri/r600_dri.so
                              3 - go to /usr/lib/dri/galium, create link to r600_dri.so and copy it to /usr/lib/dri/
                              4 - restart
                              I added the xorg-edgers ppa per #1. I presumed that apt-get update && apt-get upgrade was required, so I did that. It replaced just about every part of Xorg.

                              rather than do #2, I renamed the file to r600c_dri.so

                              There is no directory /usr/lib/dri/galium so I did not complete any part of step #3 or #4.

                              I re-named the file r600c_dri.so back to r600_dri.so

                              Kwin compositing still does not work in maverick.

                              Comment


                              • I forgot, you have to install libgl1-mesa-dri-experimental

                                Comment

                                Working...
                                X