Announcement

Collapse
No announcement yet.

[785G] Slow video playback after suspend/resume

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [785G] Slow video playback after suspend/resume

    Is this a known problem or should I report it as a bug? I'm seeing it since May and up to current git, with kernel versions 2.6.32 up to 2.6.35. It is as if the CPU (or the GPU) was half as fast as after a fresh boot. Rebooting fixes the problem. XBMC seems the most affected player (note: it doesn't use xv; xv players are not affected at all). The effect is unnoticeable with standard definition videos, but makes HD ones unwatchable; it is present both with UMS and KMS. Audio is fine.
    Thanks for any help

  • #2
    Originally posted by kbios View Post
    Is this a known problem or should I report it as a bug? I'm seeing it since May and up to current git, with kernel versions 2.6.32 up to 2.6.35. It is as if the CPU (or the GPU) was half as fast as after a fresh boot. Rebooting fixes the problem. XBMC seems the most affected player (note: it doesn't use xv; xv players are not affected at all). The effect is unnoticeable with standard definition videos, but makes HD ones unwatchable; it is present both with UMS and KMS. Audio is fine.
    Thanks for any help
    If I remember correctly, xbmc uses GL... so this *could* (i.e., this is a complete guess on my part) be a result of the GPU clock getting stuck low after a resume. Xv being unaffected suggests that this is all in the GPU and not related to the CPU.

    You might try messing with the power saving kernel options and see if you can get it to go into and stay in fast mode.... see if that helps. Maybe something like radeon.dynclks=0 on the kernel command line.

    Comment


    • #3
      Originally posted by droidhacker View Post
      If I remember correctly, xbmc uses GL... so this *could* (i.e., this is a complete guess on my part) be a result of the GPU clock getting stuck low after a resume. Xv being unaffected suggests that this is all in the GPU and not related to the CPU.

      You might try messing with the power saving kernel options and see if you can get it to go into and stay in fast mode.... see if that helps. Maybe something like radeon.dynclks=0 on the kernel command line.
      Thanks for your answer. I played a bit with power methods and profiles, and also checked the CPU, but nothing seems to work, except a reboot. Even restarting xorg is not doing anything.

      Comment


      • #4
        Please, could someone help me debugging this? I've also tried updating the BIOS, but it didn't help. Also, non GLSL games seem unaffected. What could be different after a resume? Any hint is welcome
        Thanks

        Comment


        • #5
          Well, in case anyone is having the same problem, switching to r600g solved the problem for me. That's quite strange, as AFAIK mesa/gallium run from userspace.

          Comment

          Working...
          X