Announcement

Collapse
No announcement yet.

ATI Evergreen 3D Code May Soon Go Into Gallium3D

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Evergreen 3D Code May Soon Go Into Gallium3D

    Phoronix: ATI Evergreen 3D Code May Soon Go Into Gallium3D

    AMD finally pushed out open-source 2D/3D acceleration code for Evergreen (a.k.a. the ATI Radeon HD 5000 series graphics cards) last month, but since then these drivers haven't received too much attention. AMD's few open-source developers are beginning to turn their attention to supporting the Radeon HD 6000 series more promptly in the open-source world while the community developers seem to still have their attention on the Gallium3D driver for the ATI Radeon HD 2000/3000/4000 (R600/R700) hardware...

    http://www.phoronix.com/vr.php?view=ODU4MQ

  • #2
    This is a step in the right direction. Gallium unifies so much effort from developers of the various drivers. Development will speed up a good deal if all drivers are developed inside the Gallium framework. Currently I am still an nvidia user with the gallium nvfx driver. It is really useable in terms of OpenGL.

    Comment


    • #3
      ATI open source support on Ubuntu 10.04 is too buggy and some models, are unusable.
      I have a Radeon X1650 and a Mobility Radeon X200 and they are unable to display properly Google Earth.

      Comment


      • #4
        Try installing a recent driver (not a one-year old one) and try with the Gallium-based driver. It should render Google Earth just fine. In fact, it should render just about anything just fine.

        If it doesn't work, complain to Ubuntu.

        Comment


        • #5
          fernandoc1, are you running the new Gallium3D driver (r300g) yet ? If not, suggest you give it a try.

          Comment


          • #6
            How do I install the latest drivers, without breaking the whole system?

            Comment


            • #7
              There should be packages in one of the experimental Ubuntu repositories.

              But this is quite off-topic in this thread. You can try the Open Source AMD subforum, or asking on the Ubuntu forums.

              Comment


              • #8
                @Fernandoc1,
                Ubuntu ships with old and pretty stable software. The radeon graphics drivers are improving at a very high rate, so you got a realy old driver as a result.

                The open source development 'team' is so massively undestaffed as a result of the fact that developping drivers appears to be very difficult with current generation graphics cards, that it is realy lame to simply 'thumb them down' because something doesn't work for you yet.

                Comment


                • #9
                  @Fernandoc1,
                  I had some trouble upgrading to Maverick while using the latest drivers from the xorg-edgers ppa. I'll suggest that you first upgrade your system to Maverick before you even start thinking about using the latest driver.

                  Comment


                  • #10
                    Originally posted by Silverthorn View Post
                    @Fernandoc1,
                    I had some trouble upgrading to Maverick while using the latest drivers from the xorg-edgers ppa. I'll suggest that you first upgrade your system to Maverick before you even start thinking about using the latest driver.
                    There is a good reason for this notice at the xorg-edgers ppa:

                    ** Please do not publish instructions for how to install from this archive without linking to this page! Anyone using packages from this archive is expected to read this page first and it is recommended to check back occasionally for notice on problems that may arise. **

                    Well, at the top of the page it says:

                    *IMPORTANT NOTICE* - If you are upgrading from one release to another and are using this PPA, be sure to install ppa-purge and use it to downgrade all of this PPA's packages before the upgrade or you will have a broken system.

                    I can't feel sorry for you if you are too lazy to read but can complain immediately.

                    On the other hand the packages there contain the same stuff for Maverick and Lucid so you don't need to upgrade.

                    @Fernandoc1:
                    Try the mentioned ppa after you fully read this page.
                    Here is a thread if you have further questions.

                    Comment

                    Working...
                    X