Announcement

Collapse
No announcement yet.

R600, Big Black Square around a shrunken fb/X

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • R600, Big Black Square around a shrunken fb/X

    I get a 2-3cm thick black square around the picture on my HDMI connected monitor abusing kernel 2.6.35-git3 and 2.6.35-git4 KMS. The black square comes when the kernel loads the KMS FB and stays there when starting X. X story is that I am running 1920x1080 pixels, which is supposedly correct, atleast that is the resolution I normally abuse.

    There is no black square around my screen when abusing the 2.6.35-git2 kernel.

    I have the few hours old git xf86-video-ati+libdrm+mesa technology.

    It appears that some git commit between 2.6.35-git2 and 2.6.35-git3 (and the evidence shows that there were many files changed) sets the correct resolution but somehow asks my monitor to shrink the picture, thus adding the big black frame.

    WHAT IS GOIGN ON HERE? WHY WOULD THEY DO THIS? QUE BONO?

  • #2
    It's the new "underscan" code added recently to deal with cases where an HDMI-attached TV has overscan set so users can't see the menus at boot. There's a RANDR mechanism to turn it off, will see if I can find it...

    Comment


    • #3
      xrandr --output DVI-0 --set underscan off

      (adjust for whatever your output is called)

      Comment


      • #4
        Originally posted by bridgman View Post
        xrandr --output DVI-0 --set underscan off

        (adjust for whatever your output is called)
        xrandr --output HDMI-0 --set underscan off

        Thank you. That fixed it.

        It would be better if that were some kernel command line option or xorg.conf option or better, if the code would just detect that overscan isn't set... or by default assume it's not if overscan involvement can't be detected.

        I should also mention that I did try to enable the overscan on my HDMI monitor (with --set overscan on) and the black frame around the picture was somewhat reduced, however, it did not go away.

        Overscan is a bad idea anyway, thus I believe that assuming that it's on and therefore do underscan is a bad idea. Why is it enabled and not disabled by default? What menu can't the users see at boot anyway? Grub? No, that's loaded before the kernel.. $hostname login:? kdm? gdm?

        Comment


        • #5
          I don't think the monitor reports back whether it's using overscan or not.

          It's just that *most* monitors consider anything connected via HDMI to be a TV source and use overscan.

          Comment


          • #6
            HDMI doesn't report whether it's overscanned or not. So users with TVs that overscan can't see the edges of their screen if underscan is off. TV's that don't overscan will show the black bars if underscan is enabled. We can't win

            Comment


            • #7
              Most HDMI TVs overscan by default and there's no way to detect it in the driver. Often there's no way to disable it on the TV, especially on the cheaper TVs.

              Comment


              • #8
                Originally posted by agd5f View Post
                Most HDMI TVs overscan by default and there's no way to detect it in the driver. Often there's no way to disable it on the TV, especially on the cheaper TVs.
                Thank you for the explenation.

                Could you please add some radeon module option to disable the underscan by adding something to grub? xrandr is not a good way to make permanent changes.

                Comment


                • #9
                  Originally posted by xiando View Post
                  xrandr is not a good way to make permanent changes.
                  And KDE und Gnome are not able to store smaller things like which Monitor is the Primary since radeon (KMS) has a different Output ordering..... ( #26459 )

                  Comment


                  • #10
                    I'm using a recently compiled drm-radeon-testing kernel and experience the same problem, but with my DVI output:
                    Code:
                    % xrandr 
                    Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
                    DVI-0 disconnected (normal left inverted right x axis y axis)
                    DIN disconnected (normal left inverted right x axis y axis)
                    DVI-1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 520mm x 320mm
                    xrandr --output DVI-1 --set underscan off fixes the issue.

                    Comment


                    • #11
                      Originally posted by Nille View Post
                      And KDE und Gnome are not able to store smaller things like which Monitor is the Primary since radeon (KMS) has a different Output ordering..... ( #26459 )
                      I've put the xrandr commands in /usr/share/config/kdm/Xsetup now.

                      This is no ideal solution, specially for people like my Ubuntu-using mother who has no idea what operating system she has on her computer, but it.. works.

                      Comment

                      Working...
                      X