Announcement

Collapse
No announcement yet.

Google image search suckage

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Google image search suckage

    Google changed their image search, and the performance on my Radeon HD4670 is absolutely pathetic. Scrolling down the page is excruciatingly slow.

    [959690.935] (--) RADEON(0): Chipset: "ATI RV730XT [Radeon HD 4670]


    Fedora 13: 2.6.33.6-147.fc13.x86_64 #1 SMP
    xorg-x11-server-Xorg-1.8.2-1.fc13.x86_64
    xorg-x11-server-common-1.8.2-1.fc13.x86_64
    xorg-x11-drv-ati-6.13.0-1.fc13.x86_64

    I am running the default configuration, with no xorg.conf file. Are there any fixes in the pipeline which would address this, or any flags I can set to improve performance?

  • #2
    Are you using KMS? That is indeed slow as molasses.

    Comment


    • #3
      KMS is fine here. Did you update any components (mesa, ddx, xserver, etc.) recently?

      Comment


      • #4
        Originally posted by agd5f View Post
        KMS is fine here.
        Too much CPU. It's quite OK with my Core 2 Duo. Try it on a low-end P4 and it's another story. It seems there's a lot that doesn't get handled by the GPU, and it seems it's worse with KMS when compared to UMS?

        Comment


        • #5
          I am having the same problem on a RV530. With OS X 10.6 it's a lot faster.

          Comment


          • #6
            I note that the problem does not appear in the Google Chrome browser, only in Firefox (currently 3.6.7)

            I haven't tested any other browsers yet.

            Comment


            • #7
              I think you're seeing bug 27139. See:
              https://bugs.freedesktop.org/show_bug.cgi?id=27139
              and the associated patches:
              http://lists.x.org/archives/xorg-dri...st/016827.html
              http://lists.x.org/archives/xorg-dev...st/012299.html

              Comment


              • #8
                Same here with a RS480. Google Image search is simply unusable.

                Comment


                • #9
                  I tried the 6 radeon patches (downloaded from bug #27139) and Google image search is a lot faster now.

                  Comment


                  • #10
                    Just FYI the radeon patches are now merged in current git.

                    Comment


                    • #11
                      I just built xf86-video-ati Git. Google Images received quite a speed boost. It's now actually usable

                      Comment


                      • #12
                        Originally posted by RealNC View Post
                        I just built xf86-video-ati Git. Google Images received quite a speed boost. It's now actually usable
                        That's good to hear. I'll give it a try later, but it looks like these patches are missing some Evergreen bits. Not really surprising since Evergreen hasn't been merged to master yet, and probably won't be merged before 2.6.36 is released. So I guess I'll have to add the missing bits myself manually first. sigh.

                        Comment

                        Working...
                        X