Announcement

Collapse
No announcement yet.

Software Rasterizer after reinstall Radeon

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Software Rasterizer after reinstall Radeon

    My friend tried to install fgrlx on the old video card. Naturally, he was unsuccessful and I advised him to remove fgrlx and reinstall Radeon.
    Code:
    sudo /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge xorg-driver-fglrx fglrx*
    sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
    sudo apt-get install xserver-xorg-video-ati xserver-xorg-video-radeon
    sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
    sudo dpkg-reconfigure xserver-xorg
    Then he got - OpenGL renderer string: Software Rasterizer
    Here logs http://pastebin.com/qvK0WC27
    Your advice on how to solve the problem and enable Mesa DRI.

  • #2
    Looks like there's something wrong with his kernel radeon DRM module. Does 'lsmod' show the radeon kernel module loaded? Perhaps it's being blacklisted somewhere under /etc/modprobe.d/ ?

    Adam

    Comment


    • #3
      Does 'lsmod' show the radeon kernel module loaded?
      Yes. Here log lsmod.
      Perhaps it's being blacklisted somewhere under /etc/modprobe.d/ ?
      No. Here logs all files in /etc/modprobe.d/

      Here log "dmesg | grep drm". Perhaps this will give the necessary information.

      Comment


      • #4
        Looks like he is using Ubuntu. He should have used the "Hardware Drivers" GUI to install and remove the proprietary driver... Maybe there are some hints on https://wiki.ubuntu.com/X/Troublesho...thRadeonDriver

        Comment


        • #5
          That's the problem... He's using a card unsupported by the proprietary driver, so the GUI utility would not have given him that option so apparently he decided to install them manually. Unfortunately, I don't see anything in the log files or the information provided that explains why DRI is failing.

          Adam

          Comment


          • #6
            Code:
            msk@msk-desktop:~$ dmesg | grep drm
            [ 0.000000] Linux version 2.6.32-23-generic (buildd@yellow) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 (Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5)
            [ 15.943312] [drm] Initialized drm 1.1.0 20060810
            [ 16.360313] [drm] radeon defaulting to kernel modesetting.
            [ 16.360318] [drm] radeon kernel modesetting enabled.
            [ 16.390215] [drm] radeon: Initializing kernel modesetting.
            My memory is a little fuzzy, but I have a suspicion that his libdrm version is a bit old based on the datestamp above. That might also be the cause of the DRM errors in the Xorg.log file.

            Comment


            • #7
              The date on the drm is good, the same that I'm getting here. However, now that I think about it, there should be a whole lot more output from 'dmesg | grep drm' if KMS is enabled. It should go through the whole routine of detecting attached output devices, which doesn't appear to be happening.

              Unfortunately, that doesn't really give me any other ideas about how to solve the problem for the OP.

              Adam

              Comment

              Working...
              X