Announcement

Collapse
No announcement yet.

minor issues with wine

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • minor issues with wine

    yo devs , i wish to report a little glitch in the r700 clasic radeon driver(it doesnt happen in gallium r300 btw).

    when you open a wine applications even winecfg, for few seconds after actually render anything on screen the screen flick like 4 times(black screen/desktop/black/desktop, etc).

    not sure if the issue is wine probing an extension wich is not present or something in the driver, well after that little flick all works like is meant to so np about that just reporting

  • #2
    yo?

    Are you serious?
    Stuck two decades in the past are you?

    Wine itself is a major issue. Don't use it unless you have to. If all you get is some flickering, you should consider it working -- you're ahead of the curve. I can't remember the last time I saw ANY program ***ACTUALLY WORK*** in wine.

    Comment


    • #3
      Originally posted by droidhacker View Post
      yo?

      Are you serious?
      Stuck two decades in the past are you?

      Wine itself is a major issue. Don't use it unless you have to. If all you get is some flickering, you should consider it working -- you're ahead of the curve. I can't remember the last time I saw ANY program ***ACTUALLY WORK*** in wine.
      Que? I think you're the one stuck in the past....
      http://appdb.winehq.org/index.php

      The screen flickers could possibly be something related to Wine checking for supported resolutions with randr?

      Comment


      • #4
        I'm using r600c driver on RV670 (kernel 2.3.34 + xorg-edgers). No problem seen.

        Comment


        • #5
          Originally posted by droidhacker View Post
          yo?

          Are you serious?
          Stuck two decades in the past are you?

          Wine itself is a major issue. Don't use it unless you have to. If all you get is some flickering, you should consider it working -- you're ahead of the curve. I can't remember the last time I saw ANY program ***ACTUALLY WORK*** in wine.
          well i dont know which problems you got with wine and how old are your tests, but for me rigth now using the oss driver the next software works like a charm

          * adobe dreamweaver cs4
          * adobe photoshop cs4(i use gimp mostly but for rgb32 i need photshop)
          * adobe flash cs4(for some old stuff in my site until i ended the migration to canvas html5)
          * adobe illustrator cs4 (to complement some filter missing in inkscape)
          * qt4 (is nice for testing apps without reboot- need some hacks)
          * firefox windows(again for testing render without restart too much or going to virtualbox)
          * and some others windows toys for design

          on my nvidia laptop few games like
          * lineage2 epilogue
          * wow latest update
          * l4d 1
          * simcity
          * guild of wars runs peachy
          * fallout 3
          * the old good farcry 1
          * call of duty waw (wasnt easy though)
          * devil may cry 4
          * and some more

          so for me at least is pretty decent and it perform really really well. for example devil may cry bench option give me like 10 fps less than in win7 for example

          photoshop and illustrator actually feels fully snappy, and the filter time are pretty much average with windows in most cases

          now i agree that wine need some tricks here and there to get stuff running but is getting easier with every release, beside there are many site including winehq.org wich ppl post how you can get to run the software you want if it works with wine.

          ofc i would prefer a real native qt4/kde4 application instead or a real native game, but for now wine is a good tool to use in the meantime

          Comment


          • #6
            Originally posted by whizse View Post
            Que? I think you're the one stuck in the past....
            http://appdb.winehq.org/index.php

            The screen flickers could possibly be something related to Wine checking for supported resolutions with randr?
            could be , i still thinks is more an extension missing cuz the r300 gallium driver of my other laptop doesnt show that flick or nouveau is only the r700 (i have a 4850x2).

            but a missing feature or partial implementation in xrandr could show the same symptons if wine is polling xrandr so is very plausible too.

            Comment


            • #7
              I should probably have formulated my reply better: the flickering is a bug of course, not something you should expect to see.

              An uneducated guess is that Wine checks for something related to monitor outputs, which causes a bug in the 2D driver to flicker the screen.

              Comment


              • #8
                Originally posted by whizse View Post
                I should probably have formulated my reply better: the flickering is a bug of course, not something you should expect to see.

                An uneducated guess is that Wine checks for something related to monitor outputs, which causes a bug in the 2D driver to flicker the screen.
                i think that is the exact way to describe it

                Comment


                • #9
                  It may not even be a bug. The usual cause of this flickering is an RandR request to find out what displays are attached. The hardware mechanism used for load detection causes flickering on analog outputs, not sure if any digital outputs are affected.

                  There has been a long ongoing debate about whether the RandR call should be broken up into smaller functions so that relatively more could be done without inducing flicker.

                  Comment


                  • #10
                    Originally posted by bridgman View Post
                    It may not even be a bug. The usual cause of this flickering is an RandR request to find out what displays are attached. The hardware mechanism used for load detection causes flickering on analog outputs, not sure if any digital outputs are affected.

                    There has been a long ongoing debate about whether the RandR call should be broken up into smaller functions so that relatively more could be done without inducing flicker.
                    monitors are connected through dvi and it only happens on r700, noveau and r300 gallium are unafected by the flicker at least in my tests.

                    the only thing differents beside the ovbious is that all the non flickering pc report gl2.1 when r700 report gl2.0(that why i thinked it was an extension, very empiric i know)

                    my monitor have a thing called DCR(i think it is dynamic contrast ratio), ill try to disable it somehow and test again

                    Comment


                    • #11
                      well i made another post explaining whay i think is early support for multiple gpu in the radeon driver, maybe that can cause the flick or maybe is my monitor and that dcr thing(i hate the edit time)

                      ill repost with more info later

                      Comment

                      Working...
                      X