Announcement

Collapse
No announcement yet.

Gallium on r600 imported to mesa / trunk

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Gallium on r600 imported to mesa / trunk

    It's imported to mesa trunk at last!
    let's r600g era begins

    http://cgit.freedesktop.org/mesa/mesa/

  • #2
    I'm getting the following when I try and compile:
    Code:
    make[3]: Entering directory `/home/bpaterni/git/radeon/mesa/src/gallium/targets/dri-r600'
    /bin/sh ../../../../bin/mklib -o r600_dri.so.tmp -noprefix -linker 'gcc' -ldflags '' \
    		../../../../src/mesa/drivers/dri/common/utils.o ../../../../src/mesa/drivers/dri/common/vblank.o ../../../../src/mesa/drivers/dri/common/dri_util.o ../../../../src/mesa/drivers/dri/common/xmlconfig.o   ../../../../src/gallium/state_trackers/dri/drm/libdridrm.a ../../../../src/gallium/winsys/r600/drm/libr600winsys.a ../../../../src/gallium/drivers/softpipe/libsoftpipe.a ../../../../src/gallium/drivers/trace/libtrace.a ../../../../src/gallium/drivers/r600/libr600.a \
                    -Wl,--start-group ../../../../src/mesa/libmesagallium.a ../../../../src/gallium/auxiliary/libgallium.a -Wl,--end-group \
                       -L/usr/local/lib -ldrm   -lexpat -lm -lpthread -ldl -ldrm_radeon 
    mklib: Making Linux shared library:  r600_dri.so.tmp
    if [ "x" == "x" ]; then \
    		gcc -g -O2 -Wall -Wmissing-prototypes -std=c99 -ffast-math -fvisibility=hidden -fno-strict-aliasing -g  -fPIC  -DUSE_X86_64_ASM -D_GNU_SOURCE -DPTHREADS -DDEBUG -DHAVE_POSIX_MEMALIGN -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_XEXTPROTO_71 -o r600_dri.so.test ../../../../src/mesa/drivers/dri/common/dri_test.o r600_dri.so.tmp   -L/usr/local/lib -ldrm   -lexpat -lm -lpthread -ldl -ldrm_radeon; \
    	else \
    		g++ -g -O2 -Wall -Wmissing-prototypes -std=c99 -ffast-math -fvisibility=hidden -fno-strict-aliasing -g  -fPIC  -DUSE_X86_64_ASM -D_GNU_SOURCE -DPTHREADS -DDEBUG -DHAVE_POSIX_MEMALIGN -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_XEXTPROTO_71 -o r600_dri.so.test ../../../../src/mesa/drivers/dri/common/dri_test.o r600_dri.so.tmp   -L/usr/local/lib -ldrm   -lexpat -lm -lpthread -ldl -ldrm_radeon; \
    	fi
    r600_dri.so.tmp: undefined reference to `rbug_screen_create'
    r600_dri.so.tmp: undefined reference to `rbug_enabled'
    collect2: ld returned 1 exit status
    make[3]: *** [r600_dri.so] Error 1
    make[3]: Leaving directory `/home/bpaterni/git/radeon/mesa/src/gallium/targets/dri-r600'
    make[2]: *** [default] Error 1
    make[2]: Leaving directory `/home/bpaterni/git/radeon/mesa/src/gallium/targets'
    make[1]: *** [subdirs] Error 1
    make[1]: Leaving directory `/home/bpaterni/git/radeon/mesa/src'
    make: *** [default] Error 1

    Comment


    • #3
      solved... Apparently we need to include librbug.a in the dri-r600 target:

      Code:
      ---
       src/gallium/targets/dri-r600/Makefile |    1 +
       1 files changed, 1 insertions(+), 0 deletions(-)
      
      diff --git a/src/gallium/targets/dri-r600/Makefile b/src/gallium/targets/dri-r600/Makefile
      index ecf2671..0213200 100644
      --- a/src/gallium/targets/dri-r600/Makefile
      +++ b/src/gallium/targets/dri-r600/Makefile
      @@ -8,6 +8,7 @@ PIPE_DRIVERS = \
              $(TOP)/src/gallium/winsys/r600/drm/libr600winsys.a \
              $(TOP)/src/gallium/drivers/softpipe/libsoftpipe.a \
              $(TOP)/src/gallium/drivers/trace/libtrace.a \
      +       $(TOP)/src/gallium/drivers/rbug/librbug.a \
              $(TOP)/src/gallium/drivers/r600/libr600.a
      
       C_SOURCES = \
      -- 
      1.7.1

      Comment


      • #4
        OpenGL vendor string: X.Org
        OpenGL renderer string: Gallium 0.4 on R600/R700 (HD2XXX,HD3XXX,HD4XXX)
        OpenGL version string: 2.1 Mesa 7.9-devel
        OpenGL shading language version string: 1.20


        that's all what works for now it seems

        Comment


        • #5

          Comment


          • #6
            WoW, glxgears not working on my RS780

            Comment


            • #7
              WoW? You are a REAL optimist

              Comment


              • #8
                I don't think the 600g code is expected to run glxgears yet. Jerome was pretty explicit about that in his post.

                Comment


                • #9
                  Therefore glxgears running is a bug, and needs to be reported?

                  Comment


                  • #10
                    Assuming you want it "corrected" (ie made not to run at all rather than partially rendering) then yes, of course

                    Comment

                    Working...
                    X