Announcement

Collapse
No announcement yet.

How to do tripple head with with 2 radeon cards and radeonhd driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to do tripple head with with 2 radeon cards and radeonhd driver

    Is there any example xorg.conf for having 2 ati cards with 3 or 4 monitors connected?

    I simply cannot get it to work. I have added 2 Device entries (each having a BusId) and two screen sections (one for each device) in xorg.conf. Each works when I only use one screen in the Layout section.

    I'd like to have the same setup as in windows with a desktop spanning over all three screens. The monitors all have different resolutions.

    Furthermore I'd like to use compiz and docky.

    Here is the hardware I use:

    ATI 4850 PCI:1:0:0:
    middle: Samsung 24 inch DVI
    right: Iyama 22 inch DVI

    ATI 4550 PCI:2:0:0:
    left: Medion 19 inch VGA

    I am using Ubuntu 10.04 x64

  • #2
    you need to enable Xinerama and provide the screens and positions in the ServerLayout.

    be aware though that Xinerama + composite (as used by compiz) has a few bugs which are unlikely to get fixed.

    Did you try radeon instead of radeonhd? They're different enough to warrant trying the other in case of exotic problems.


    Can you attach your xorg.conf so far?

    Comment


    • #3
      you really need kms to use multiple cards.

      Comment


      • #4
        I tried something similar: https://bugzilla.redhat.com/show_bug.cgi?id=596545
        (multi gpu; panning across screens)

        Jerome Glisse 2010-05-27 04:22:54 EDT
        You can't do that, you can only have 1 Xserver per GPU and xinerama is not
        supported with randr1.2 thus you can't reunite the 2 Xserver to have one
        desktop. Only thing you can do is 1 desktop on each GPU (then matter is how to
        switch keyboard/mouse btw the 2 Xserver).

        Comment


        • #5
          you could also search for zaphod mode in this forum and see if it answers your need

          Comment


          • #6
            hello,

            in case you're still looking for solution:
            use radeon driver instead and take a look at this page:
            http://wiki.debian.org/XStrikeForce/HowToRandR12

            I've got dualhead working flawlessly with XRandr 1.2

            Comment

            Working...
            X