Announcement

Collapse
No announcement yet.

Radeon KMS bug causing wireless crashes, devs please help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I'm not convinced this is the fault of the radeon driver. Seems more like it might be an irq or timer problem. Having radeon kms loaded may just aggravate it since it uses irqs and timers more than ums did.

    Comment


    • #12
      Originally posted by agd5f View Post
      Please try my suggestions on the bug report.
      Hi Alex, thanks for your help. I tried disabling msi, with no effect. In fact, the first time I booted with msi disabled it hung at the splash screen, but sorted itself out on the second boot cycle. Still drops wireless. Running with msi on and radeon kms disabled restores normal operation.

      Originally posted by agd5f View Post
      I'm not convinced this is the fault of the radeon driver. Seems more like it might be an irq or timer problem. Having radeon kms loaded may just aggravate it since it uses irqs and timers more than ums did.
      You are probably on to something there, but what sort of information do you need to test? I can provide logs if you let me know which ones you need.

      Comment


      • #13
        Originally posted by agd5f View Post
        I'm not convinced this is the fault of the radeon driver. Seems more like it might be an irq or timer problem. Having radeon kms loaded may just aggravate it since it uses irqs and timers more than ums did.
        I hope this problem gets taken seriously. My laptop (Thinkpad T60) is virtually useless with radeon KMS enabled. I think the sound issues plus wireless ones together point the finger at Radeon KMS.

        Anyway, I'm running fine with UMS for the time being.

        Comment


        • #14
          I am probably also affected by that. I think I didnt had problem for a while with KMS and Gallium because of using ethernet only. Now airmon-ng is running half of a day, and KMS xorg hangs very early.

          I got UXGA T60p with FireGL V5200, and xorg 1.8.x, d-r-t and master DDX/Mesa/drm

          Comment


          • #15
            I switched to KMS/Gallium and after airmon-ng running over 20ours no crash at all in KMS. I had only two blackscreens when playing Quake3 in Gallium/KMS/pageflip after reverting Obcene_CNN Mesa patch(which didnt applied fully - maybe its the reason). With this patch partially applied Quake3 hanged usually in less than minute. I am talking about Gallium, because Classic is generally broken with KMS PageFlip for r500(in xorg.conf). And with PageFlip disabled q3a is laggy in 1600x1200 and frame flow is not smooth. (with PageFlip it is for mine r500). In Classic/PageFlip theres often hang with OpenGL app(permament for fullscreen apps), in every GL window, and to eliminate it xorg restart is needed(and sometimes module reloading)

            Comment

            Working...
            X