Announcement

Collapse
No announcement yet.

Do I need to replace libglx.so?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Do I need to replace libglx.so?

    Hello, I tried without success to install the last proprietary beta drivers of ATI.

    Now, backing to the opensource xf86-video-ati drivers (I'm using the last git commit), I don't have 3D, and I guess this is the problem from Xorg.0.Log:

    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    (II) Module glx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.4.0, module version = 1.0.0
    (II) Loading extension GLX


    I'm using Debian/Testing with a X1300 Mobility Radeon, and the glxinfo output is:

    name of display: :0.0
    X Error of failed request: BadRequest (invalid request code or no such operation)
    Major opcode of failed request: 135 (GLX)
    Minor opcode of failed request: 19 (X_GLXQueryServerString)
    Serial number of failed request: 15
    Current serial number in output stream: 15


    How can I solve this? I don't have a clue of how replacing libglx.so if I'm right and this is the problem.

    Thanks in advance.

  • #2
    Could be a version mismatch. I understand the new catalyst drivers don't support xserver 1.7?

    Comment


    • #3
      Solved:

      Sorry for this post, I just reinstalled xserver-xorg-core (I didn't know where was the libglx.so until I've googled a little bit more) and everything is fine again.

      Comment

      Working...
      X