Announcement

Collapse
No announcement yet.

hd 4650 (mobility) doesn't work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • hd 4650 (mobility) doesn't work

    I followed this tutorial https://help.ubuntu.com/community/RadeonHD (using prebuilt packages) but my card just doesn't work, the opengl renderer is always software rasterizing. The Xorg log file shows that my modified xorg.conf file has been parsed correctly.

  • #2
    What kernel and mesa versions are you running ? Did you upgrade the kernel and mesa (from ppa) or just radeonhd ?

    Comment


    • #3
      the kernel is the one suggested in the tutorial, 2.6.33. I don't know the mesa version, is the version number shown in the packets manager the right one? if it's so, it's 7.8.0

      Comment


      • #4
        I upgrade everything the ppa showed me.

        Comment


        • #5
          When asking for help, you should always include relevant log files. /var/log/Xorg.0.log, 'dmesg | grep drm' would certainly be a start.

          Adam

          Comment


          • #6
            the first time I posted there, I didn't really activate radeonhd, but just radeon. With radeonhd both 2d and 3d acceleration is off, with radeon 2d is on.
            so, here's the xorg.conf, the log file for radeonhd and the dmesg dump.
            as you can see, there are troubles detecting the screen (stuff not recognized) and loading the firmware.

            http://www.webalice.it/micioptah/radeon.tar.gz

            I first installed the new kernel, then, before rebooting, copied the firmware to /lib/firmware/radeon. was it there the mistake? If so, must I re-install the kernel?

            Comment


            • #7
              I have posting what you asked, but the post didn't show up yet because it contained a link.
              Anyway, the problem was that the kernel couldn't find the radeon firmware. Now, only power management is left.

              Comment


              • #8
                just to let you know, I had to disable KMS.

                Comment

                Working...
                X