Announcement

Collapse
No announcement yet.

[KMS, 2.6.33/34rc1] HDMI output turns off atfter 10 minutes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [KMS, 2.6.33/34rc1] HDMI output turns off atfter 10 minutes

    Hi,

    i'm using lucid with the latest bits from xorg-edgers. Since 2.6.33rc* (i can't seem to recall exactly where it started) the HDMI output turns off (both video&sound) after exactly 10 minutes. 2.6.34rc1 has the same issue. If I press Alt+F1 and then go back to F7, display comes back for another 10 minutes (moving the mouse/pressing keys won't help).

    If i turn kms off (boot option radeon.modeset=0) everything works fine.

    Code:
    lspci -v |grep VGA
    01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4200]
    Anyone else having this issue?

  • #2
    Originally posted by tzu23 View Post
    Hi,

    i'm using lucid with the latest bits from xorg-edgers. Since 2.6.33rc* (i can't seem to recall exactly where it started) the HDMI output turns off (both video&sound) after exactly 10 minutes. 2.6.34rc1 has the same issue. If I press Alt+F1 and then go back to F7, display comes back for another 10 minutes (moving the mouse/pressing keys won't help).

    If i turn kms off (boot option radeon.modeset=0) everything works fine.

    Code:
    lspci -v |grep VGA
    01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4200]
    Anyone else having this issue?
    Two questions:

    1) Does it happen when you are USING it? Or after 10 minutes of *inactivity*?
    2) LOG OUTPUT WHEN IT HAPPEN!!!!! (try ssh'ing into the box and dumping your logs.)

    I notice an odd thing with a completely different system, which may or may not be related (I'm leaning towards not, but if it IS related, it might help out an investigation).... PSB drivers, KMS(-ish?), GMA500, kernel 2.6.32, Xserver 1.6.4, about 10 minutes of INACTIVITY (haven't actually timed it...) and the screen goes black, won't wake up unless I VT and back to X (same like you describe).

    Comment


    • #3
      hi,

      1.) a plasma screen is connected to the hdmi output. the screen goes off regardless of whether i am active (i.e. moving the mouse, etc), doing nothing or just watching a movie.
      2.) i'll try it again with .34rc3 and see what it outputs.

      Comment

      Working...
      X