Announcement

Collapse
No announcement yet.

Recommended xorg.conf setup for radeonhd on Mobility Radeon X1400

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Recommended xorg.conf setup for radeonhd on Mobility Radeon X1400

    Hi, I have a Dell Inspiron 6400 with an ATI Mobility Radeon X1400. I'm using radeonhd driver on linux 2.6.32-trunk-686 (Debian Squeeze). I would like to get suggestions as to which options I should allow on xorg.conf, or where I can find information to improve the driver's performance.

    Right now it's pretty crappy. It used to work really well with fglrx, but since it's not supported on newer kernels, I haven't been able to use it.

    So, I decided maybe there's a way I can get radeonhd to work decently on my laptop before I install an older kernel for fglrx. I'm not looking for 3D support (not aware if it's already available on the driver), but it would be nice anyways. Full screen video playback is extremely slow, sometimes it locks for a few seconds.

    Recommendations?

  • #2
    Originally posted by fernandou View Post
    Full screen video playback is extremely slow
    using xv or ogl? xv will probably work better.

    http://www.x.org/wiki/radeonhd%3Afeature
    http://www.x.org/wiki/RadeonFeature

    3D should work with both. Have you tried radeon to see if it makes any difference? It seems that radeon is currently better maintained and receives more fixes and features.

    Comment


    • #3
      Which version of libdrm and mesa?

      Have you tried the radeon driver?

      With or without KMS?

      Comment


      • #4
        Which version of libdrm and mesa?
        I have this version of libdrm2 installed. I guess it was automatically installed.

        When I search for installed mesa packages, I get:

        Code:
        dpkg --get-selections | grep mesa
        libgl1-mesa-dri                                 install       
        libgl1-mesa-glx                                 install       
        libglu1-mesa                                    install
        Versions: 7.6.1-1


        Have you tried the radeon driver?
        Yes, after your answers I did, and not much has changed.

        With or without KMS?
        using xv or ogl? xv will probably work better.

        No idea...
        Since I'm pretty much a noob here, I'll paste my xorg.conf to see if that can give you a better idea of my configuration. I haven't done anything manually, just Xorg -configure, so the file was made automatically:

        Code:
        Section "Device"
                ### Available Driver options are:-
                ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
                ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
                ### [arg]: arg optional
                #Option     "NoAccel"            	# [<bool>]
                #Option     "AccelMethod"        	# [<str>]
                #Option     "offscreensize"      	# [<str>]
                #Option     "SWcursor"           	# [<bool>]
                #Option     "ignoreconnector"    	# [<str>]
                #Option     "forcereduced"       	# [<bool>]
                #Option     "forcedpi"           	# <i>
                #Option     "useconfiguredmonitor" 	# [<bool>]
                #Option     "HPD"                	# <str>
                #Option     "NoRandr"            	# [<bool>]
                #Option     "RROutputOrder"      	# [<str>]
                #Option     "DRI"                	# [<bool>]
                #Option     "TVMode"             	# [<str>]
                #Option     "ScaleType"          	# [<str>]
                #Option     "UseAtomBIOS"        	# [<bool>]
                #Option     "AtomBIOS"           	# [<str>]
                #Option     "UnverifiedFeatures" 	# [<bool>]
                #Option     "Audio"              	# [<bool>]
                #Option     "AudioStreamSilence" 	# [<str>]
                #Option     "HDMI"               	# [<str>]
                #Option     "COHERENT"           	# [<str>]
                #Option     "ForceLowPowerMode"  	# [<bool>]
                #Option     "LowPowerModeEngineClock" 	# <i>
        	Identifier  "Card0"
        	Driver      "radeon"
        	VendorName  "ATI Technologies Inc"
        	BoardName   "Radeon Mobility X1400"
        	BusID       "PCI:1:0:0"
        EndSection

        Comment


        • #5
          Which version of libdrm and mesa?
          Mesa packages installed:
          Code:
          dpkg --get-selections | grep mesa
          libgl1-mesa-dri                                 install
          libgl1-mesa-glx                                 install
          libglu1-mesa                                    install
          Version: 7.6.1-1

          DRM:
          Code:
          dpkg --get-selections | grep drm
          libdrm-intel1                                   install
          libdrm2                                         install
          Version: 2.4.11+git+20090630+de1ed01-1

          With or without KMS?
          using xv or ogl?
          No clue... I'm pretty much a n00b here, maybe my Device section from my xorg.conf file may give you an idea. It was automatically generated with Xorg -configure. I only changed the driver to radeon as you suggested, but nothing has changed:

          Code:
          Section "Device"
                  ### Available Driver options are:-
                  ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
                  ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
                  ### [arg]: arg optional
                  #Option     "NoAccel"            	# [<bool>]
                  #Option     "AccelMethod"        	# [<str>]
                  #Option     "offscreensize"      	# [<str>]
                  #Option     "SWcursor"           	# [<bool>]
                  #Option     "ignoreconnector"    	# [<str>]
                  #Option     "forcereduced"       	# [<bool>]
                  #Option     "forcedpi"           	# <i>
                  #Option     "useconfiguredmonitor" 	# [<bool>]
                  #Option     "HPD"                	# <str>
                  #Option     "NoRandr"            	# [<bool>]
                  #Option     "RROutputOrder"      	# [<str>]
                  #Option     "DRI"                	# [<bool>]
                  #Option     "TVMode"             	# [<str>]
                  #Option     "ScaleType"          	# [<str>]
                  #Option     "UseAtomBIOS"        	# [<bool>]
                  #Option     "AtomBIOS"           	# [<str>]
                  #Option     "UnverifiedFeatures" 	# [<bool>]
                  #Option     "Audio"              	# [<bool>]
                  #Option     "AudioStreamSilence" 	# [<str>]
                  #Option     "HDMI"               	# [<str>]
                  #Option     "COHERENT"           	# [<str>]
                  #Option     "ForceLowPowerMode"  	# [<bool>]
                  #Option     "LowPowerModeEngineClock" 	# <i>
          	Identifier  "Card0"
          	Driver      "radeon"
          	VendorName  "ATI Technologies Inc"
          	BoardName   "Radeon Mobility X1400"
          	BusID       "PCI:1:0:0"
          EndSection
          I also detected some errors:
          Code:
          cat /var/log/Xorg.0.log | grep EE
                  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
          (II) Loading extension MIT-SCREEN-SAVER
          (EE) open /dev/fb0: No such file or directory
          (EE) ioctl EVIOCGNAME failed: Inappropriate ioctl for device
          (EE) PreInit returned NULL for ""SynPS/2 Synaptics TouchPad""
          Maybe this can help you get a better idea of my situation.

          Comment


          • #6
            Your chipset should be well supported by this. First thing you should try is removing everything related to fglrx from your system. Completely deinstall, like it was never there. It messes everything up and doesn't play nicely with OSS drivers.

            Second thing you should try is running the radeon (xf86-video-ati) driver instead of RadeonHD. Both of them should work, but it's worth a shot.

            Third thing you should do is post the output of glxinfo |grep ender

            Comment


            • #7
              Also, what's the output of xvinfo?

              try running X without any xorg.conf

              Comment


              • #8
                First thing you should try is removing everything related to fglrx from your system. Completely deinstall, like it was never there. It messes everything up and doesn't play nicely with OSS drivers.
                Apparently its gone, I checked for installed packages so far:
                Code:
                dpkg --get-selections | grep fglrx
                fglrx-atieventsd                                deinstall
                fglrx-driver                                    deinstall
                fglrx-glx                                       deinstall
                Nothing installed apparently.

                glxinfo:

                Code:
                glxinfo | grep ender
                direct rendering: Yes
                OpenGL renderer string: Software Rasterizer
                xvinfo:
                Code:
                xvinfo
                X-Video Extension version 2.2
                screen #0
                 no adaptors present
                How can I configure the way Xorg runs? I know I can specify a file with -config file, but how can I be certain I'm using this file?

                Comment


                • #9
                  X reads /etc/X11/xorg.conf by default.

                  Comment


                  • #10
                    Originally posted by RealNC View Post
                    X reads /etc/X11/xorg.conf by default.
                    Apparently not, there is no xorg.conf file on /etc/X11.

                    Comment

                    Working...
                    X