Announcement

Collapse
No announcement yet.

Recommended xorg.conf setup for radeonhd on Mobility Radeon X1400

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    This looks problematic:

    "(II) RADEON(0): XAA Render acceleration unsupported on Radeon 9500/9700 and newer. Please use EXA instead."

    The default is EXA but for some reason the driver tries to use XAA. Try forcing EXA with:

    Code:
    Section "Device"
    	Identifier  "X1400"
    	Driver      "radeon"
    	Option      "AccelMethod" "EXA"
    EndSection

    Comment


    • #17
      I would not switch to EXA till you get direct rendering working. What is the output of 'dmesg | grep drm' and 'lsmod | grep drm'?

      Adam

      Comment


      • #18
        Code:
        lsmod | grep drm
        drm_kms_helper         17183  1 radeon
        drm                   107507  3 radeon,ttm,drm_kms_helper
        i2c_core               12612  4 radeon,drm,i2c_algo_bit,i2c_i801
        agpgart                19516  3 ttm,drm,intel_agp
        dmesg | grep drm

        Thanks all for your help! I'll get this to work...

        Comment


        • #19
          You need to install the Debian kernel firmware package. It's called firmware-linux.

          Then you need to unload and reload the radeon kernel module (or simply reboot). Once Direct Rendering is working, switch to the EXA AccelMethod per RealNC's instructions.

          Comment


          • #20
            Yes.

            Currently, neither 3d acceleration nor EXA is working. No wonder everything is slow.

            Both are supported on your chipset with your currently installed drivers, but you will need the firmware.

            Comment


            • #21
              I installed linux firmware and now video playback works fine

              Thanks a lot for your help!

              I'm using EXA as AccelMethod, should I enable and try DRI? Is there any more tweaking recommended?

              Comment


              • #22
                I expect DRI is already enabled.

                Comment


                • #23
                  Try "glxinfo | grep ender", or "glxgears" to see whether 3D is working.

                  Comment


                  • #24
                    glxgears shows 3D is working:

                    Code:
                    glxgears
                    2900 frames in 5.0 seconds = 579.368 FPS
                    You guys rule!
                    Thanks for helping me out on this one. How did you know it was linux-firmware I needed to install?

                    Comment


                    • #25
                      It's a common issue with Debian.

                      Adam

                      Comment


                      • #26
                        I have a similar problem with X1400

                        Hi guys. I have encountered some problems with my X1400 too, but I guess mine is somewhat different.

                        Here is the setting of my debian.

                        Code:
                        kernel 2.6.32-2-686
                        and some related packages
                        Code:
                        xserver-common            2:1.7.4-2
                        xserver-xephyr            2:1.7.4-2
                        xserver-xorg              1:7.5+3
                        xserver-xorg-core         2:1.7.4-2
                        xserver-xorg-video-radeon 1:6.12.99+
                        And also some DRM stuffs
                        Code:
                        libdrm-intel1             2.4.17-1
                        libdrm-radeon1            2.4.17-1
                        libdrm2                   2.4.17-1
                        MESA libs
                        Code:
                        libgl1-mesa-dri           7.7-3
                        libgl1-mesa-glx           7.7-3
                        libglu1-mesa              7.7-3
                        firmwares
                        Code:
                        firmware-linux-free       2.6.32-8
                        firmware-linux            0.22
                        firmware-linux-nonfree    0.22
                        I think my problem is related to DRI stuffs. I found the following error in the Xorg.0.log:
                        Code:
                        (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
                        [dri] This chipset requires a kernel module version of 1.17.0,
                        [dri] but the kernel reports a version of 2.0.0.[dri] If using legacy modesetting, upgrade your kernel.
                        [dri] If using kernel modesetting, make sure your module is
                        [dri] loaded prior to starting X, and that this driver was built
                        [dri] with support for KMS.
                        [dri] Disabling DRI.
                        I have enabled KMS in the following way but it might be causing trouble.
                        add a .conf file to /etc/modprobe.d/
                        which says
                        Code:
                        options radeon modeset=1
                        Before I started using KMS, I tried both XAA and EXA acceleration methods. glsgears runs faster with XAA. And I think at that time DRI is working. In many 3D games, like bzflag, it is reported using hardware acceleration but now it is purely software rasterization.

                        Is it that KMS causing the DRI error? Is it possible to enable DRI when KMS is working?

                        And another thing might be related is that the console. Usu. I simply login via the text-mode console (instead of gdm). I used to set a vga parameter at boot time in GRUB (which I have disabled now). It is said KMS conflicts with the framebuffer driver and it avoids the flickering when the X server starts, because KMS uses the video card. But after I enabled the KMS, and now whenever I start the X with the command startx, the console goes black (while the X is functioning normally). I can switch to any console with C-A-Fn, but it is simply black without any text displayed. And even when I quit the X, the console does not restore. It might still respond to key-strokes.

                        Here is the related dmesg information related:
                        Code:
                        $ dmesg | grep drm
                        [   38.538358] [drm] Initialized drm 1.1.0 20060810
                        [   38.639371] [drm] radeon kernel modesetting enabled.
                        [   38.642271] [drm] radeon: Initializing kernel modesetting.
                        [   38.642302] [drm] register mmio base: 0xEE100000
                        [   38.642304] [drm] register mmio size: 65536
                        [   38.642642] [drm] GPU reset succeed (RBBM_STATUS=0x10000140)
                        [   38.642677] [drm] Generation 2 PCI interface, using max accessible memory
                        [   38.642681] [drm] radeon: VRAM 128M
                        [   38.642683] [drm] radeon: VRAM from 0x00000000 to 0x07FFFFFF
                        [   38.642685] [drm] radeon: GTT 512M
                        [   38.642688] [drm] radeon: GTT from 0x20000000 to 0x3FFFFFFF
                        [   38.642870] [drm] radeon: irq initialized.
                        [   38.643514] [drm] Detected VRAM RAM=128M, BAR=128M
                        [   38.643518] [drm] RAM width 128bits DDR
                        [   38.644822] [drm] radeon: 128M of VRAM memory ready
                        [   38.644825] [drm] radeon: 512M of GTT memory ready.
                        [   38.644841] [drm] GART: num cpu pages 131072, num gpu pages 131072
                        [   38.647731] [drm] RB2D reset succeed (RBBM_STATUS=0x10000140)
                        [   38.647768] [drm] radeon: 1 quad pipes, 1 z pipes initialized.
                        [   38.647840] [drm] PCIE GART of 512M enabled (table at 0x00040000).
                        [   38.647854] [drm] radeon: cp idle (0x10000C03)
                        [   38.647901] [drm] Loading R500 Microcode
                        [   38.693369] [drm] radeon: ring at 0x0000000020000000
                        [   38.693425] [drm] ring test succeeded in 4 usecs
                        [   38.693715] [drm] radeon: ib pool ready.
                        [   38.693888] [drm] ib test succeeded in 0 usecs
                        [   38.695389] [drm] Radeon Display Connectors
                        [   38.695394] [drm] Connector 0:
                        [   38.695397] [drm]   VGA
                        [   38.695403] [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
                        [   38.695407] [drm]   Encoders:
                        [   38.695411] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
                        [   38.695415] [drm] Connector 1:
                        [   38.695418] [drm]   LVDS
                        [   38.695423] [drm]   DDC: 0x7e60 0x7e60 0x7e64 0x7e64 0x7e68 0x7e68 0x7e6c 0x7e6c
                        [   38.695428] [drm]   Encoders:
                        [   38.695431] [drm]     LCD1: INTERNAL_LVTM1
                        [   38.695435] [drm] Connector 2:
                        [   38.695438] [drm]   DVI-I
                        [   38.695443] [drm]   DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
                        [   38.695447] [drm]   Encoders:
                        [   38.695451] [drm]     DFP1: INTERNAL_KLDSCP_TMDS1
                        [   39.159540] [drm] fb mappable at 0xD80C0000
                        [   39.159543] [drm] vram apper at 0xD8000000
                        [   39.159545] [drm] size 5913600
                        [   39.159547] [drm] fb depth is 24
                        [   39.159549] [drm]    pitch is 5632
                        [   39.159554] fb: conflicting fb hw usage radeondrmfb vs EFI VGA - removing generic driver
                        [   39.159640] fb1: radeondrmfb frame buffer device
                        [   39.159648] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
                        Thanks for any advice!

                        Comment


                        • #27
                          KMS is enabled in time X starts, but radeon driver thinks that it should still use UMS. To sum it all - you should enable KMS before starting X. The .conf in /etc/modprobe.d didn't work for me, and doesn't work for you too. Maybe try rebuilding your initramfs? (sudo update-initramfs -u on Ubuntu, Debian uses similar initrd packages AFAIK). If that doesn't work for you, try adding "radeon.modeset=1" to kernel cmdline (by altering /etc/default/grub.
                          These two solutions didn't work for me, but I'm using 33rcX kernels, not mainline ones.

                          Comment


                          • #28
                            Also, while KMS does need to be enabled *before* Xorg starts up, xserver-xorg-video-radeon does need to be KMS aware. I'm not sure if Debian enables that.

                            Adam

                            Comment


                            • #29
                              Originally posted by Wielkie G View Post
                              KMS is enabled in time X starts, but radeon driver thinks that it should still use UMS. To sum it all - you should enable KMS before starting X. The .conf in /etc/modprobe.d didn't work for me, and doesn't work for you too. Maybe try rebuilding your initramfs? (sudo update-initramfs -u on Ubuntu, Debian uses similar initrd packages AFAIK). If that doesn't work for you, try adding "radeon.modeset=1" to kernel cmdline (by altering /etc/default/grub.
                              These two solutions didn't work for me, but I'm using 33rcX kernels, not mainline ones.
                              Sorry I don't quite understand... KMS has been enabled ever since the kernel loads the initramfs into memory and calls module-init-tools script, IMO. The evidence is that the booting information is displayed in a console of native resolution of the video card.

                              so, if u r saying my initramfs has some problems, the KMS should be started during booting. I think when the kernel was installed by dpkg system, it called a proper script to make the initramfs. But to verify this I would like to manually make one as u suggested later.

                              Wel, the boot arg might be another way. I didn't try this because I saw somewhere it is said the debian kernel now does not support this. It will fail to load a firmware. But anyway, I'd like to try it too.

                              Send you guys the result later. Thanks!

                              Comment


                              • #30
                                BTW, here is the support of KMS, if I understand their conversation correctly:
                                http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=567999
                                Code:
                                Changes: 
                                 xserver-xorg-video-ati (1:6.12.99+git20100201.a887818f-1) experimental; urgency=low
                                 .
                                   * New upstream release snapshot.
                                     + EXA now enabled by default, closes: #502970.
                                     + Fix display watermark, closes: #540954.
                                     + Add KMS support, closes: #561526, #567999.
                                   * Bump libdrm-dev dependency to 2.4.17 to get libdrm-radeon.
                                   * Build-depend on x11proto-dri2-dev for DRI2 support.
                                And my radeon is at version 1:6.12.99+git20100201.a887818f-1. So...

                                Comment

                                Working...
                                X