Announcement

Collapse
No announcement yet.

Evergreen (aka r800) seems to be entering in the radeon git master

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Evergreen (aka r800) seems to be entering in the radeon git master

    Hi,

    I was just looking the the recent commits:
    http://cgit.freedesktop.org/xorg/dri...video-ati/log/

    and it seems that evergreen is getting some attention:
    6 hours evergreen: blank/unblank DP in dpms callsmaster Alex Deucher 1 -3/+11
    7 hours evergreen: pll fixes Alex Deucher 1 -13/+12
    19 hours evergreen: DP requires coherent mode Alex Deucher 1 -1/+1
    19 hours evergreen: fix units on frac_fb_div Alex Deucher 1 -1/+1
    46 hours evergreen: add pci ids Alex Deucher 6 -0/+210
    46 hours evergreen: add atombios crtc/pll functions Alex Deucher 4 -28/+252
    46 hours evergreen: add atom support for digital outputs Alex Deucher 4 -29/+276
    46 hours evergreen: add crtc set base/format support Alex Deucher 2 -2/+112
    46 hours evergreen: add lut support Alex Deucher 1 -20/+41
    46 hours evergreen: add hw cursor support Alex Deucher 1 -4/+64
    46 hours evergreen: add base asic support Alex Deucher 4 -14/+172
    46 hours evergreen: add register and utility defines Alex Deucher 1 -0/+149
    46 hours evergreen: add chip enums Alex Deucher 1 -1/+8
    Is anyone already running a 5xxx gpu with the oss radeon driver? Or is that not possible yet? If it is please do post instruction since i want to run it as well!

    Regards,
    Mark

  • #2
    O and look at this post: http://www.botchco.com/agd5f/?p=48 (from Alex Deucher, the one that made those commits)

    Comment


    • #3
      Old News: http://www.phoronix.com/scan.php?pag...item&px=Nzk0Ng
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Originally posted by Michael View Post
        ^_^ missed that news post

        Comment


        • #5
          Oh yeah! got it working with my 5770! Sadly my card doesn't seem to have supported power management from the xf86-video-ati driver but i read somewhere (on this forum?) that the 2.6.34 kernel is likely to either support it or provide the basics so the driver can support it.

          Awesome so far

          Comment


          • #6
            You can add:

            Code:
            Option      "ForceLowPowerMode" "true"
            to your xorg.conf. This will run the card with the engine and memory clocks on half of the normal frequencies.

            Comment


            • #7
              Originally posted by monraaf View Post
              You can add:

              Code:
              Option      "ForceLowPowerMode" "true"
              to your xorg.conf. This will run the card with the engine and memory clocks on half of the normal frequencies.
              Thanx for the line although it's not working here...
              After adding that line i had to boot from another linux distro and remove the line since my screen was just black! Removing it solved the issue.

              Comment


              • #8
                Originally posted by markg85 View Post
                Thanx for the line although it's not working here...
                After adding that line i had to boot from another linux distro and remove the line since my screen was just black! Removing it solved the issue.
                Maybe because the HD5XXX Serie has currently only MOdesettings Support nothing more.

                Comment


                • #9
                  Interesting. It was working for me, but when I lowered the clocks to fglrx levels I experienced the same thing as you. Maybe it is because shadowfb is being used, I don't know. I'll give it another try when there's EXA support.

                  Comment

                  Working...
                  X