Announcement

Collapse
No announcement yet.

Radeon Gallium on ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    I'm currently toying with getting a PPA that has gallium enabled to make it easy for people to test. In theory, all I should need to do is depend on the xorg-edgers PPA, copy the version of mesa from there, and add the --enable-gallium-radeon flag to my PPA's version of mesa, no?

    Well, I got it to build, and I'm about to test it (although I don't have an r300-r500 card at the moment). If anyone's interested, I have Lucid version right now: https://launchpad.net/~dtl131/+archive/mediahacks

    Comment


    • #62
      I have an ATI 1800XL (R520), I will install your PPA at my home computer and try it. I hope I do not screw up something. How do I get upates for the latest Gallium3D mesa? I have the Xorg Edgers crak ppa installed. Do you I get auto update?

      Comment


      • #63
        How to install it? I could not download said package, and synaptic could not find your pack after I did add your source ppa

        Comment


        • #64
          Originally posted by Beiruty View Post
          How to install it? I could not download said package, and synaptic could not find your pack after I did add your source ppa
          I think the edgers PPA version deprecated mine. You could probably select it in Synapitc under the versions tab. Unfortunately, I would advise you to build from source if you want to try gallium because I'm going to be away from the computer world for a while because of medical issues.

          Comment


          • #65
            Hi,
            I've a 9600XT (RV350), latest mesa git, latest libdrm (git), gentoo-sources-2.6.33, xorg-server 1.7.6


            OpenGL vendor string: X.Org R300 Project
            OpenGL renderer string: Gallium 0.4 on RV350
            OpenGL version string: 1.5 Mesa 7.9-devel
            >> nexuiz is sloooooooooow (can't really move the mouse..), and I think "OpenGL version string:" should be 2.0 or something like that.. any ideas?

            Thx!

            Comment


            • #66
              Originally posted by Dragonix View Post
              Hi,
              and I think "OpenGL version string:" should be 2.0 or something like that.. any ideas?
              Gallium reports OpenGL 2.0 only on r500 cards as far as I know. I think Marek said it somewhere but I'm too lazy to look it up.

              Comment


              • #67
                Originally posted by HokTar View Post
                Gallium reports OpenGL 2.0 only on r500 cards as far as I know. I think Marek said it somewhere but I'm too lazy to look it up.
                ah ok, thanks, that explains the opengl-1.5... though.. shouldn't i be able to play nexuiz? I mean, I can start nexuiz, but than everything is to slow (as already told, i can't move the mouse/exit nexuiz/..).

                Comment


                • #68
                  Originally posted by Dragonix View Post
                  ah ok, thanks, that explains the opengl-1.5... though.. shouldn't i be able to play nexuiz? I mean, I can start nexuiz, but than everything is to slow (as already told, i can't move the mouse/exit nexuiz/..).
                  Dunno about nexuiz. However, openarena is reported to be working nicely, so you should try that one just to check if your setup is working correctly. If it does then you might try to report the problem with nexuiz on dri-devel.

                  Comment


                  • #69
                    IIRC there are a couple of effects which need to be turned off for Nexuiz to run fast on <GL 2.0 - bloom was one, forget the other.

                    Comment


                    • #70
                      Motion Blur as well I think.

                      Comment


                      • #71
                        Hm.. I can't disable more effects
                        quake3-bin, ioquake3 and openarena give me an average of 0 fps Oo (didn't know that this is even possible...).
                        I think I just screwed it up
                        Any ideas? Any logs that could help?

                        Comment


                        • #72
                          68 fps in UrbanTerror with Gallium.

                          Comment


                          • #73
                            When do we expect a package to test Gallium3d on Radeon 500?

                            Comment


                            • #74
                              Originally posted by Beiruty View Post
                              When do we expect a package to test Gallium3d on Radeon 500?
                              I'm using mesa/gallium/r530 and building my own package. Trying to keep it as current as I can, basically it is xorg-edgers debian/ with '--enable-gallium-radeon' and a link between 'dri/radeong_dri.so' and 'dri/r300_dri.so'.

                              https://launchpad.net/~freshgraphics/+archive/ppa

                              It works quite well with desktop and video usage, haven't tested games really more than that something is lacking to play Warcraft III. It could also be because of my special FireGL card but I'm not sure.

                              $ glxinfo | grep OpenGL
                              OpenGL vendor string: X.Org R300 Project
                              OpenGL renderer string: Gallium 0.4 on RV530
                              OpenGL version string: 2.1 Mesa 7.9-devel
                              OpenGL shading language version string: 1.20
                              OpenGL extensions:

                              Comment


                              • #75
                                I was using my xedgers latest and now I have latest of 04-03-2010. How do I downgrade to your package? I added your ppa to my source list. However, Xedgers is superseding your package. I deselected xedgers from the source list and did a refresh however I still have xedger versions.

                                Thanks for your help.

                                Comment

                                Working...
                                X