Announcement

Collapse
No announcement yet.

Radeon Gallium on ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thanks for the replies. Having updated to the latest xorg-edgers I am also seeing a BIG improvement on openarena - I am now getting approx 60FPS on r300g which is significantly faster than the 44FPS I was getting on r300

    I am also getting in excess of 1600 FPS on glxgears, so it seems that a recent update has made some significant improvements.

    Google Earth is slightly faster than it was, however it is still too slow to use, so not sure what's up with that.

    I haven't been able to try Nexuiz yet I'm afraid.

    For general desktop use I have found the Gallium driver very reliable - barely any difference between r300 and r300g in this respect, but that's probably to be expected.

    Overall I have been very impressed with the r300g driver so far, and is clear that issues are being resolved a fast rate - keep up the good work!!!

    Comment


    • For the last week or so, Gallium3d updates are killing Compiz. My desktop locks up after being displayed. I need to rotate the cube to see screen updates. Frustrating. There is bug report already open.

      Comment


      • I've found that compiz works just fine with the latest r300g driver if you set LIBGL_ALWAYS_INDIRECT to 1

        Comment


        • Originally posted by adamk View Post
          I've found that compiz works just fine with the latest r300g driver if you set LIBGL_ALWAYS_INDIRECT to 1
          Where do you set that?

          Comment


          • How are you starting compiz?

            Adam

            Comment


            • Originally posted by adamk View Post
              How are you starting compiz?

              Adam
              I guess, by enabling Special Effects in Ubuntu 10.04. I have cmopiz manager installed where I can select and enable compiz features.

              Comment


              • Bah... I just remembered that Ubuntu did something really stupid and stopped using compiz-manager as the default script for starting compiz, so I'm not sure if there is a supported way to enable LIBGL_ALWAYS_INDIRECT for compiz in Ubuntu these days.

                I guess you could install fusion-icon (which I believe is still in the Ubuntu repos) and use that to start compiz. Inside fusion-icon there is an option to enable Indirect Rendering.

                Adam

                Comment


                • Same problem here. No screen updates.

                  Comment


                  • Had same problem - the latest update seems to have fixed it.

                    Comment


                    • Dear tormod and sarvatt,

                      what is your plan, when will you add the r600g driver to the xorg-edgers ppa? It can already run glxgears and ioquake games (if I remember correctly), so it might be in a state to start testing it/regularly checking out how it evolves.

                      Thanks in advance!

                      Comment

                      Working...
                      X