Announcement

Collapse
No announcement yet.

Planeshift: unplayable, almost everything is gray and white

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Planeshift: unplayable, almost everything is gray and white

    Am I the only one who can't play this game?
    I have an R600 (Radeon HD3870), does it work with R300/R500?
    I also opened a bug report:
    http://bugs.freedesktop.org/show_bug.cgi?id=26103

    This is a screenshot of the game
    http://darkbasic.homelinux.com/image...shift_bug.jpeg
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

  • #2
    Can someone with R300/R500 test if it works?
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

    Comment


    • #3
      looks liks broken support for textures compression

      Comment


      • #4
        I don't know if it is connected to the planeshift issue but this is nexuiz piece-o-cake first location (effects set to low):
        http://darkbasic.homelinux.com/image...fterglsl1.jpeg

        This is nexuiz with effects set to high:
        http://darkbasic.homelinux.com/image...fterglsl2.jpeg

        I noticed theese problems after the merging of the glsl patches.



        This is nexuiz with effects set to low (every map except piece-o-cake):
        http://darkbasic.homelinux.com/images/nexuiz_low.jpeg

        Everything seems to be ok in the last screenshot (here I even enabled texture compression to test if it works).
        ## VGA ##
        AMD: X1950XTX, HD3870, HD5870
        Intel: GMA45, HD3000 (Core i5 2500K)

        Comment


        • #5
          Full pslaunch.sh log:
          http://pastebin.com/m2a21af5

          In-game planeshift screenshot:
          http://darkbasic.homelinux.com/image...ft_ingame.jpeg
          ## VGA ##
          AMD: X1950XTX, HD3870, HD5870
          Intel: GMA45, HD3000 (Core i5 2500K)

          Comment


          • #6
            Looks like it's missing a bunch of files, including shaders and textures. Is that normal ?

            Comment


            • #7
              I don't know, I did a md5checksum before starting planeshift (pslaunch's repair) and all files were in place. I have some strange warnings in nexuiz too (in the piece-o-cake demo):

              R_LoadTexture: bogus texture size (0x0x1x32bppx1sides = 0 bytes)
              R_Water_ProcessPlanes: Error: texture creation failed! Turned off r_water.

              I already posted on planeshift forums to see if it is normal or not.
              ## VGA ##
              AMD: X1950XTX, HD3870, HD5870
              Intel: GMA45, HD3000 (Core i5 2500K)

              Comment


              • #8
                I installed the official binaries and I have the same output and the same problems: it is definitely a driver problem.

                This is the thread on the planeshift forum:
                http://www.hydlaaplaza.com/smf/index.php?topic=36743.0
                ## VGA ##
                AMD: X1950XTX, HD3870, HD5870
                Intel: GMA45, HD3000 (Core i5 2500K)

                Comment


                • #9
                  similar (or the same) graphic problems with the game Regnum Online. I have a Radeon HD 4650.

                  screenshots of the game (with new radeon drivers and a Radeon 4650):
                  http://img263.imageshack.us/img263/6...raphicprob.jpg
                  http://img263.imageshack.us/img263/5...aphicprobo.jpg


                  With Catalyst drivers everything is fine in this game.

                  A few lines of the error log file of the game:
                  [20/01/2010 22:07:25] [RenderizerGL][renderizer_gl_x11.cpp(334)] BadMatch (invalid parameter attributes)
                  [20/01/2010 22:07:35] [RenderizerGL][renderizer_gl__textures.cpp(519)] OpenGL: invalid value
                  [20/01/2010 22:07:35] [RenderizerGL][renderizer_gl__textures.cpp(669)] Error uploading texture : invalid value
                  [20/01/2010 22:07:35] [Texture Manager][texture_manager.cpp(181)] Error uploading texture, resource ID: 61742
                  [20/01/2010 22:07:39] [=?(0)] scripts/interface/admin/game_control.lua not found!
                  [...]
                  Last edited by Fenrin; 01-20-2010, 05:12 PM.

                  Comment


                  • #10
                    If I disable texture compression it works!
                    http://darkbasic.homelinux.com/image...-disabled.jpeg

                    Video.OpenGL.MesaForceS3TCEnable = no
                    in data/config/r3dopengl.cfg
                    ## VGA ##
                    AMD: X1950XTX, HD3870, HD5870
                    Intel: GMA45, HD3000 (Core i5 2500K)

                    Comment

                    Working...
                    X