Announcement

Collapse
No announcement yet.

RadeonHD dual screen issue with a Kohjinsha DZ

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RadeonHD dual screen issue with a Kohjinsha DZ

    You probably heard about the Kohjinsha DZ:



    Well, I'm having some trouble with the dual screen using the RadeonHD driver (the video card is a Radeon HD 3200).

    The extended desktop is ok, but the right screen seems kind of "blur". It's like if some columns where missing.

    See this image: http://nyquil.org/uploads/IndianHeadTestPattern16x9.png
    on the right screen: http://img709.imageshack.us/img709/2240/indiantest.jpg

    Here's a perfect quality DivX: http://img31.imageshack.us/img31/2571/divxy.jpg

    $ cat /etc/services : http://img13.imageshack.us/img13/187...tcservices.jpg

    The problem is exactly the same in clone mode. I tried to plug a screen on the external VGA, it works perfectly (dual screen with the left screen).

    I use X.Org X Server 1.6.5 and radeonhd 1.3.0.

    Here's the xorg.conf file: http://pastebin.ca/raw/1737837
    Here's "xrandr" output: http://pastebin.ca/raw/1732437
    Here's the Xorg.0.log file: http://pastebin.ca/raw/1745723

    Any ideas?

    Thanks.

  • #2
    Nobody?

    I also tried fglrx, but X freezes at startup.
    Last edited by Cl3x; 01-26-2010, 01:54 PM.

    Comment


    • #3
      You might try the radeon driver (xf86-video-ati). I'd also be curious to see the a copy of the vbios from that device.

      Comment


      • #4
        The right screen is detected but stays black with the radeon driver.

        Edit : it seems be blinking sometimes.
        Last edited by Cl3x; 01-26-2010, 03:46 PM.

        Comment


        • #5
          Originally posted by Cl3x View Post
          X cannot be launched at all with the radeon driver.
          Are you using the latest code from git? Can you pastebin your xorg log?

          Comment


          • #6
            Originally posted by agd5f View Post
            Are you using the latest code from git? Can you pastebin your xorg log?
            I edited my post just before yours. =)

            I'm using xf86-video-ati-6.12.4

            Comment


            • #7
              Any chance you could try xf86-video-ati from git master?

              Comment


              • #8
                Originally posted by agd5f View Post
                Any chance you could try xf86-video-ati from git master?
                I just tried it, it does not change anything. :/

                Comment


                • #9
                  Can you pastebin your xorg log?

                  Comment


                  • #10
                    My bad, I didn't install them properly.

                    So, it's better, almost perfect actually.
                    The right screen is just a little blur. I'm gonna try to take a picture of this.

                    Edit :

                    Well, it's strange. The right screen is blur only on extended desktop mode, not in clone mode. :/

                    Here's the Xorg.0.log : http://pastebin.ca/1767085

                    The xorg.conf didn't change (except the s/radeonhd/radeon/).


                    Re-edit :
                    After some changes with xrandr, the right screen does not seem blur anymore.
                    So thank you very much.
                    Last edited by Cl3x; 01-26-2010, 04:36 PM.

                    Comment

                    Working...
                    X