Announcement

Collapse
No announcement yet.

Radeon/KMS and KDE4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon/KMS and KDE4

    Hello,
    I am posting the first time here, so I apologize if that was mentioned already...

    I activated KMS and compiled the git-versions of xorg-server, libdrm, mesa, xf86-input-ati (distribution: gentoo).

    So far, all is fine, glxgears gives 1900fps (Radeon HD 4670) and I can play UT2004-demo without problems or graphical errors.

    BUT: turning on the desktop effects does not work:
    when using OpenGl the speed is so slow, that the system becomes unusable;
    when using "XRender" I cannot use most of the effects, like snow or the desktop-switching-cube. It does not matter if I am using kernel 2.6.32.3 or a 2.6.33-rcX - problem is the same.

    does anybody else experience similar problems and how do you solve it?
    TIA

  • #2
    Some of the effects require OpenGL and won't work with XRender.

    You should post your Xorg.0.log to a pastebin and link it here, the answer is probably in it.

    Code:
    grep -E "WW|EE" /var/log/Xorg.0.log

    Comment


    • #3
      [
      Code:
      grep -E "WW|EE" /var/log/Xorg.0.log
      [/QUOTE]

      ok, this is the result:
      cat /var/log/Xorg.0.log | grep EE
      Current Operating System: Linux brain 2.6.32.3 #2 SMP PREEMPT Thu Jan 7 18:41:19 CET 2010 x86_64
      (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
      (II) Loading extension MIT-SCREEN-SAVER
      (EE) Failed to load module "vesa" (module does not exist, 0)
      (EE) Failed to load module "fbdev" (module does not exist, 0)
      (EE) HID 046a:0050: failed to initialize for relative axes.


      btw: I dont know if that has sth. to do with my problem, but running glxinfo with normal user rights, I get:

      glxinfo
      name of display: :0.0
      display: :0 screen: 0
      direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
      server glx vendor string: SGI
      server glx version string: 1.2


      ... so direct rendering does not work? running it as root gives me:

      name of display: :0.0
      IRQ's not enabled, falling back to busy waits: 2 0
      display: :0 screen: 0
      direct rendering: Yes
      server glx vendor string: SGI
      server glx version string: 1.2

      thx

      Comment


      • #4
        For the "vesa" and "fbdev" errors, add "fbdev vesa" to VIDEO_CARDS in your /etc/make.conf. In other words, for the radeon driver you need:

        VIDEO_CARDS="fbdev vesa radeon"

        after that, do:

        emerge -auDN world

        (VIDEO_CARDS expands to USE flags so the emerge will pick up the changes.)

        Comment


        • #5
          Originally posted by flockmock View Post
          btw: I dont know if that has sth. to do with my problem, but running glxinfo with normal user rights, I get:

          glxinfo
          name of display: :0.0
          display: :0 screen: 0
          direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
          server glx vendor string: SGI
          server glx version string: 1.2
          Sounds like you're not in the video-group. Try gpasswd -a <user> video.

          Comment


          • #6
            thanks for the answers. the error messages after the suggestions from RealNC are now:

            cat /var/log/Xorg.0.log | grep EE
            Current Operating System: Linux brain 2.6.33-rc4 #5 SMP PREEMPT Wed Jan 13 21:36:22 CET 2010 x86_64
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
            (II) Loading extension MIT-SCREEN-SAVER
            (EE) open /dev/fb0: No such file or directory
            (EE) HID 046a:0050: failed to initialize for relative axes.

            all users are in the video group. still unbearable openGL performance. ..strange

            Comment


            • #7
              Are you using an /etc/X11/xorg.conf file? Try using this:

              Code:
              Section "Device"
              	Identifier  "HD4670"
              	Driver      "radeon"
              EndSection
              and make sure the "Screen" section says:

              Code:
              Device "HD4670"
              Also append this at the end:

              Code:
              Section "DRI"
              	Mode         0666
              EndSection
              Also, please use http://pastebin.ca/ to post your entire /var/log/Xorg.0.log as well as the output of the "dmesg" command.

              Comment


              • #8
                I changed the xorg.conf file according to your suggestions, no change.

                my dmesg:
                http://pastebin.ca/1756800

                my /var/log/Xorg.0.log:
                http://pastebin.ca/1756808

                thx a lot!

                Comment


                • #9
                  Are you a member of the group that owns /dev/dri/card0 ?

                  Adam

                  Comment


                  • #10
                    (WW) RADEON(0): Option "GARTSize" is not used
                    (WW) RADEON(0): Option "VideoOverlay" is not used
                    (WW) RADEON(0): Option "OpenGLOverlay" is not used
                    (WW) RADEON(0): Option "TexturedVideo" is not used
                    (WW) RADEON(0): Option "XAANoOffscreenPixmaps" is not used
                    (WW) RADEON(0): Option "UseInternalAGPGART" is not used
                    seems you have a lot of old cruft in xorg.conf, get rid of it.

                    Comment


                    • #11
                      Originally posted by flockmock View Post
                      I changed the xorg.conf file according to your suggestions, no change.

                      my dmesg:
                      http://pastebin.ca/1756800

                      my /var/log/Xorg.0.log:
                      http://pastebin.ca/1756808

                      thx a lot!
                      Nothing in those logs jumps at me as "wrong."

                      I'll give here the exact xorg.conf and exact versions of the packages I used to get KMS working on my HD4870. Kernel was 2.6.33 rc4. Note that the only live ebuild (-9999) I used was for xf86-video-ati. Everything else were regular releases, not Git versions.

                      Make sure x11-drivers/ati-drivers is not installed. Also make sure you're not having ATI's OpenGL lib still active. To ensure this, do a:

                      Code:
                      eselect opengl set xorg-x11
                      This will ensure you're using Mesa, not the GL from fglrx.

                      First, my xorg.conf. Try to use it as-is first; don't add anything else (I hope you have HAL enabled for X so you get mouse and keyboard automatically.)

                      Code:
                      Section "ServerLayout"
                      	Identifier  "Simple Layout"
                      	Screen      0  "Screen 1"  0  0
                      EndSection
                      
                      
                      Section "Monitor"
                      	Identifier  "Monitor[0]"
                      	Option	    "DPMS"  "true"
                      EndSection
                      
                      
                      Section "Device"
                      	Identifier  "HD4870"
                      	Driver      "radeon"
                      	Option	    "ForceLowPowerMode"  "on"
                      EndSection
                      
                      
                      Section "Screen"
                      	Monitor    "Monitor[0]"
                      	Identifier "Screen 1"
                      	Device     "HD4870"
                      EndSection
                      
                      
                      Section "DRI"
                      	Mode         0666
                      EndSection
                      And the versions of the packages I used:

                      Code:
                      x11-apps/mesa-progs-7.7
                      x11-apps/xinput-1.5.0
                      x11-base/xorg-drivers-1.7
                      x11-base/xorg-server-1.7.4
                      x11-drivers/xf86-video-ati-9999  <-- The only live ebuild I used
                      x11-libs/libdrm-2.4.17
                      x11-libs/libX11-1.3.2
                      x11-libs/libXScrnSaver-1.2.0
                      x11-libs/libXext-1.1.1
                      x11-libs/libXi-1.3
                      x11-libs/libXinerama-1.1
                      x11-libs/libXtst-1.1.0
                      x11-libs/libXxf86dga-1.1.1
                      x11-libs/libXxf86vm-1.1.0
                      x11-proto/bigreqsproto-1.1.0
                      x11-proto/fixesproto-4.1.1
                      x11-proto/inputproto-2.0
                      x11-proto/recordproto-1.14
                      x11-proto/scrnsaverproto-1.2.0
                      x11-proto/xcmiscproto-1.2.0
                      x11-proto/xextproto-7.1.1
                      x11-proto/xf86bigfontproto-1.2.0
                      x11-proto/xf86dgaproto-2.1
                      x11-proto/xf86driproto-2.1.0
                      x11-proto/xf86vidmodeproto-2.3
                      x11-proto/xineramaproto-1.2
                      Last edited by RealNC; 01-19-2010, 06:37 AM.

                      Comment


                      • #12
                        The first thing you should try is deleting xorg.conf.

                        Comment


                        • #13
                          tried all of the above, some packages got updates, result stays the same. perhaps my Radeon HD 4670 is just too weak to provide decent openGL performance...?

                          nevertheless, thanks all for your help, I will continue to try the latest kernels/drivers and will post here if I have success.

                          Comment


                          • #14
                            Originally posted by flockmock View Post
                            tried all of the above, some packages got updates, result stays the same. perhaps my Radeon HD 4670 is just too weak to provide decent openGL performance...?

                            nevertheless, thanks all for your help, I will continue to try the latest kernels/drivers and will post here if I have success.
                            Your HD 4670 should *easily* be fast enough. Unfortunately I can't help with your problem

                            Comment


                            • #15
                              This seems like a permissions issue. Make sure you have permission to use DRI2.

                              Comment

                              Working...
                              X