Announcement

Collapse
No announcement yet.

Change Kernel in Ubuntu Lucid

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Change Kernel in Ubuntu Lucid

    Hi,

    After installing lucid alpha 2 and enable xorg-edgers, radeon OSS is working great! i have kms and dri2 and i am runing some opengl test now. WOW!! great progress.

    But what i cant understand is that if i change the kernel from 2.6.32.10 (lucid a2 default) to 2.6.33.rc4 my screen turns black, ubuntu doesn't boot.

    I tried 3 workarounds without success:

    1) Edit /etc/initramfs-tools/modules and add radeon. Run update-initramfs -k all -u

    2) Add R600_rlc.bin and R700_rlc.bin to /lib/firmware/radeon/ and to /lib/firmware/2.6.33-020633rc4-generic/radeon/

    3) Edit /etc/modprobe.d/radeon.conf and add options radeon modeset=1

    any ideas?

  • #2
    Is there any useful info in the dmesg or xorg.log output ?

    Comment


    • #3
      Originally posted by Jimbo View Post
      Hi,

      After installing lucid alpha 2 and enable xorg-edgers, radeon OSS is working great! i have kms and dri2 and i am runing some opengl test now. WOW!! great progress.

      But what i cant understand is that if i change the kernel from 2.6.32.10 (lucid a2 default) to 2.6.33.rc4 my screen turns black, ubuntu doesn't boot.

      I tried 3 workarounds without success:

      1) Edit /etc/initramfs-tools/modules and add radeon. Run update-initramfs -k all -u

      2) Add R600_rlc.bin and R700_rlc.bin to /lib/firmware/radeon/ and to /lib/firmware/2.6.33-020633rc4-generic/radeon/

      3) Edit /etc/modprobe.d/radeon.conf and add options radeon modeset=1

      any ideas?
      i test this on my r300 test system to yesterday.

      2.6.33 do not end in an blackscreen only you can also press key ctrg-alt-f2

      then you have a init3? console!,,,

      yes on my system to 2.6.33 fails to start X on this setting.

      to blacklist your kernel for the next boot
      just edit your
      vi /boot/grub/grub.cfg

      put some '#' in the 2.6.33 session..

      Comment


      • #4
        Originally posted by bridgman View Post
        Is there any useful info in the dmesg or xorg.log output ?
        I can confirm the bug.

        and its hart to post the xorg.log or dmesg here because only a init3 bash work...

        if you give some help/instruction i can post this here.

        Comment


        • #5
          Originally posted by Qaridarium View Post
          I can confirm the bug.

          and its hart to post the xorg.log or dmesg here because only a init3 bash work...

          if you give some help/instruction i can post this here.
          dmesg > file.txt

          And similarly for xorg.log. Then open the file with your working config and paste it where you like.

          Comment


          • #6
            Originally posted by chaos386 View Post
            dmesg > file.txt

            And similarly for xorg.log. Then open the file with your working config and paste it where you like.
            ok thank you...

            Comment


            • #7
              xorg.0.log:

              http://paste.debian.net/56768/

              dmesg:

              http://paste.debian.net/56769/

              Comment


              • #8
                Code:
                [   49.093468] [drm] radeon defaulting to userspace modesetting.
                Your kernel isn't using KMS. The 33rc4 isn't reacting on radeon.modeset=1 on my setup. I created this diff which have to be applied on top of /usr/share/initramfs-tools/scripts/init-top/framebuffer:
                Code:
                --- framebuffer 2010-01-15 18:58:06.865600765 +0100
                +++ /usr/share/initramfs-tools/scripts/init-top/framebuffer     2010-01-11 17:56:27.017420971 +0100
                @@ -70,6 +70,10 @@
                                FB=${x#*=}
                                FB="${FB%%:*}"
                                OPTS="$(parse_video_opts "${x}")"
                +               ;;
                +       radeon.modeset=1)
                +               FB=radeon
                +               OPTS="modeset=1"
                        esac
                 done
                And then initrd must be updated.

                Comment

                Working...
                X