Announcement

Collapse
No announcement yet.

Suspending fails on OSS radeon driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Suspending fails on OSS radeon driver

    Suspending isn't working for me with Fedora12 on OSS radeon driver.
    I have used Fedora12 since beta.

    Current set of packages:
    xorg-x11-drv-ati-6.13.0-0.20.20091221git4b05c47ac.fc12.x86_64
    kernel-2.6.32.3-10.fc12.x86_64 (koji) / kernel-2.6.31.9-174.fc12.x86_64
    xorg-x11-server-Xorg-1.7.4-1.fc12.x86_64

    Card:
    Ati Radeon 4830 (RV770LE)

    My bug:
    https://bugzilla.redhat.com/show_bug.cgi?id=532201

  • #2
    I created the following file and it started to work. Maybe it will help you too?

    Code:
    bash-3.1$ cat /etc/pm/config.d/unload_modules 
    SUSPEND_MODULES="video"
    before that my laptop went to sleep, but never woke up. I had to reset it manually.

    now it works

    Comment


    • #3
      Originally posted by dolphin77 View Post
      I created the following file and it started to work. Maybe it will help you too?

      Code:
      bash-3.1$ cat /etc/pm/config.d/unload_modules 
      SUSPEND_MODULES="video"
      before that my laptop went to sleep, but never woke up. I had to reset it manually.

      now it works
      Thanks for the tip, but it didn't solve my problem.

      I have read about problems system not waking up from suspend, but my situation is a bit different as my system doesn't even suspend properly. Fans stay on after suspend and black screen is shown under KMS (see bugreport).

      Just tried suspending in single user mode with: echo "mem" > /sys/power/state => No luck.

      Comment

      Working...
      X