Announcement

Collapse
No announcement yet.

No DRI with 2.6.33-909

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No DRI with 2.6.33-909

    Hello everybody.
    It seems that I have no DRI with 2.6.33-999 and packages from xorg-edgers,
    on my ATI Mobility Radeon X2300.
    I get the following:

    Code:
    [dri] This chipset requires a kernel module version of 1.17.0,
    [dri] but the kernel reports a version of 2.0.0.[dri] If using legacy modesetting, upgrade your kernel.
    [dri] If using kernel modesetting, make sure your module is
    [dri] loaded prior to starting X, and that this driver was built
    [dri] with support for KMS.
    [dri] Disabling DRI.
    I also get somewhere:
    Code:
    (II) [KMS] drm report modesetting isn't supported.
    Kernel reports:
    Code:
    dmesg | grep modesetting
    [   30.756307] [drm] radeon kernel modesetting enabled.
    [   30.758646] [drm] radeon: Initializing kernel modesetting.
    It works ok with my 2.6.32. Anybody has any clue?

    Thank you.

  • #2
    Originally posted by PapadakosPanagiotis View Post
    Hello everybody.
    It seems that I have no DRI with 2.6.33-999 and packages from xorg-edgers,
    on my ATI Mobility Radeon X2300.
    I get the following:

    Code:
    [dri] This chipset requires a kernel module version of 1.17.0,
    [dri] but the kernel reports a version of 2.0.0.[dri] If using legacy modesetting, upgrade your kernel.
    [dri] If using kernel modesetting, make sure your module is
    [dri] loaded prior to starting X, and that this driver was built
    [dri] with support for KMS.
    [dri] Disabling DRI.
    I also get somewhere:
    Code:
    (II) [KMS] drm report modesetting isn't supported.
    Kernel reports:
    Code:
    dmesg | grep modesetting
    [   30.756307] [drm] radeon kernel modesetting enabled.
    [   30.758646] [drm] radeon: Initializing kernel modesetting.
    It works ok with my 2.6.32. Anybody has any clue?

    Thank you.

    I had the same issue, but never ever got it to work with kernel 2.6.33. Even after 3 hours of help within the #radeon irq. Nobody knew what was wrong.

    I tried recompiling libdrm, drm, mesa and ddx from git repos, because xorg-edgers PPA (lucid) did the same. I even tried 2.6.32 drm-next branch, which also did the same.

    Comment


    • #3
      I've had problems in the past with Ubuntu and KMS. I think the culprit is this as pointed out by the message.

      make sure your module is loaded prior to starting X.
      try adding radeon modeset=1 to /etc/modules and maybe remove that Ubuntu splash screen junk from grub.

      Comment


      • #4
        Originally posted by monraaf View Post
        I've had problems in the past with Ubuntu and KMS. I think the culprit is this as pointed out by the message.



        try adding radeon modeset=1 to /etc/modules and maybe remove that Ubuntu splash screen junk from grub.
        I have configured radeon to load with modeset=1
        Code:
        cat /etc/modprobe.d/radeon.conf
        options radeon modeset=1
        and dmesg:
        Code:
        [   31.274602] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
        [   31.420067] Console: switching to colour frame buffer device 160x50
        How can I see if the module is loaded before starting X?
        Also if this is the case, shouldn't it work
        if I restarted X?
        Last edited by PapadakosPanagiotis; 01-12-2010, 11:33 AM.

        Comment


        • #5
          Originally posted by PapadakosPanagiotis View Post
          I have configured radeon to load with modeset=1
          Code:
          cat /etc/modprobe.d/radeon.conf
          options radeon modeset=1
          AFAIK that doesn't load the module, it just sets the modeset option when the module is loaded. Just try as I told you.

          How can I see if the module is loaded before starting X?
          You get DRI2

          Comment


          • #6
            Originally posted by PapadakosPanagiotis View Post
            and dmesg:
            Code:
            [   31.274602] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
            [   31.420067] Console: switching to colour frame buffer device 160x50
            It's not working, you should also see:
            Code:
            [drm] radeon kernel modesetting enabled.
            Originally posted by PapadakosPanagiotis View Post
            How can I see if the module is loaded before starting X?
            Also if this is the case, shouldn't it work
            if I restarted X?
            It's not enough to restart X, the module itself must be unloaded and reloaded. Now, the modprobe.d should take care of it, but apparently it's failing... maybe the initrd has an outdated copy of the file?

            The best way to check is to do thinks manually:
            - stop X
            - unload radeon
            - modprobe fbcon
            - modprobe radeon modeset=1
            - check that KMS is active
            - retry with X

            Comment


            • #7
              [QUOTE=tettamanti;107632]It's not working, you should also see:
              Code:
              [drm] radeon kernel modesetting enabled.
              If you look my first post you will see that kms works.
              Code:
              [   30.429488] [drm] Initialized drm 1.1.0 20060810                                                                                                                                                                  
              [   30.756307] [drm] radeon kernel modesetting enabled.                                                                                                                                                              
              [   30.756376] radeon 0000:01:00.0: setting latency timer to 64                                                                                                                                                      
              [   30.758646] [drm] radeon: Initializing kernel modesetting.                                                                                                                                                        
              [   30.759233] [drm] register mmio base: 0xFC000000                                                                                                                                                                  
              [   30.759235] [drm] register mmio size: 65536                                                                                                                                                                       
              [   30.759334] ATOM BIOS: M64M                                                                                                                                                                                       
              [   30.759566] [drm] GPU reset succeed (RBBM_STATUS=0x10000140)                                                                                                                                                      
              [   30.759589] [drm] Generation 2 PCI interface, using max accessible memory                                                                                                                                         
              [   30.759592] [drm] radeon: VRAM 64M                                                                                                                                                                                
              [   30.759594] [drm] radeon: VRAM from 0x00000000 to 0x03FFFFFF                                                                                                                                                      
              [   30.759596] [drm] radeon: GTT 512M                                                                                                                                                                                
              [   30.759598] [drm] radeon: GTT from 0x20000000 to 0x3FFFFFFF                                                                                                                                                       
              [   30.759721]   alloc irq_desc for 31 on node -1                                                                                                                                                                    
              [   30.759724]   alloc kstat_irqs on node -1                                                                                                                                                                         
              [   30.759742] radeon 0000:01:00.0: irq 31 for MSI/MSI-X                                                                                                                                                             
              [   30.759752] [drm] radeon: using MSI.                                                                                                                                                                              
              [   30.759796] [drm] radeon: irq initialized.                                                                                                                                                                        
              [   30.760385] [drm] Detected VRAM RAM=64M, BAR=64M                                                                                                                                                                  
              [   30.760388] [drm] RAM width 64bits DDR                                                                                                                                                                            
              [   30.760504] [TTM] Zone  kernel: Available graphics memory: 1028298 kiB.                                                                                                                                           
              [   30.760522] [drm] radeon: 64M of VRAM memory ready                                                                                                                                                                
              [   30.760524] [drm] radeon: 512M of GTT memory ready.                                                                                                                                                               
              [   30.760551] [drm] GART: num cpu pages 131072, num gpu pages 131072                                                                                                                                                
              [   30.763428] [drm] RB2D reset succeed (RBBM_STATUS=0x10000140)                                                                                                                                                     
              [   30.763451] [drm] radeon: 1 quad pipes, 1 z pipes initialized.                                                                                                                                                    
              [   30.763505] [drm] PCIE GART of 512M enabled (table at 0x00040000).                                                                                                                                                
              [   30.763533] [drm] radeon: cp idle (0x10000C03)                                                                                                                                                                    
              [   30.763604] [drm] Loading R500 Microcode                                                                                                                                                                          
              [   30.763609] platform radeon_cp.0: firmware: requesting radeon/R520_cp.bin                                                                                                                                         
              [   30.840484] [drm] radeon: ring at 0x0000000020000000                                                                                                                                                              
              [   30.840529] [drm] ring test succeeded in 3 usecs                                                                                                                                                                  
              [   30.840631] [drm] radeon: ib pool ready.                                                                                                                                                                          
              [   30.840749] [drm] ib test succeeded in 0 usecs                                                                                                                                                                    
              [   30.840876] [drm] Default TV standard: NTSC                                                                                                                                                                       
              [   30.840902] [drm] Radeon Display Connectors                                                                                                                                                                       
              [   30.840904] [drm] Connector 0:                                                                                                                                                                                    
              [   30.840905] [drm]   VGA                                                                                                                                                                                           
              [   30.840908] [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c                                                                                                                                  
              [   30.840910] [drm]   Encoders:                                                                                                                                                                                     
              [   30.840912] [drm]     CRT1: INTERNAL_KLDSCP_DAC1                                                                                                                                                                  
              [   30.840914] [drm] Connector 1:                                                                                                                                                                                    
              [   30.840915] [drm]   LVDS
              [   30.840916] [drm]   Encoders:
              [   30.840918] [drm]     LCD1: INTERNAL_LVTM1
              [   30.840919] [drm] Connector 2:
              [   30.840921] [drm]   S-video
              [   30.840922] [drm]   Encoders:
              [   30.840923] [drm]     TV1: INTERNAL_KLDSCP_DAC2
              [   31.272738] No connectors reported conncted with modes
              [   31.274517] [drm] fb mappable at 0xF00C0000
              [   31.274519] [drm] vram apper at 0xF0000000
              [   31.274521] [drm] size 4096000
              [   31.274522] [drm] fb depth is 24
              [   31.274524] [drm]    pitch is 5120
              [   31.274595] fb0: radeondrmfb frame buffer device
              [   31.274597] registered panic notifier
              [   31.274602] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
              [   31.420067] Console: switching to colour frame buffer device 160x50

              Comment


              • #8
                add "modprobe radeon" after the line
                "initctl emit starting-dm DM=gdm"
                in /etc/init/gdm.conf

                Comment


                • #9
                  Well it seems that radeon is loaded too late with my 2.6.33 (around 30 seconds after loading kernel), while in 2.6.32 it is loaded 1 sec after loading kernel. So probably this is the problem...

                  Edit:
                  Well I fixed it by loading radeon to initramfs.
                  1) I edited /etc/initramfs-tools/modules
                  and added radeon
                  2) Run update-initramfs -k all -u
                  Last edited by PapadakosPanagiotis; 01-13-2010, 10:08 AM.

                  Comment


                  • #10
                    Yeah, in your case it probably was that drm got loaded by X instead of before X (initrd or inbuilt).

                    Comment

                    Working...
                    X