Announcement

Collapse
No announcement yet.

RadeonHD 4670 trouble

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RadeonHD 4670 trouble

    Okay, I've been trying to do it all by myself, and I've been failing miserably when the directions make it stupid-proof.

    Well, I've broken the stupid-proofness.

    Anyway, I have the HD 4670. I know there's radeon and radeonhd. I've read guides saying to install radeon. I've done the ppas, tried installing through the git, and compiling. Heck, I don't even know what I'm really talking about. At the end of the day, I've been getting the black screen of death over and over.

    My linux-kernel is the latest that's out though. I did that right, at least.

    Two weeks ago, I managed to get radeonhd to work. I had no compiz support or any other desktop features, and then I randomly had blue lines going vertically across my screen, whether I'm booting or in gnome. I heard updating to 2.6.33-rc3 fixes that, but nothing has changed on my end.

    So the question. What guide should I follow. Should I keep trying to use radeon, or should I just go back ahead and put radeonhd back on? And which instructions should I follow so that I'm not constantly fixing my xorg and starting over?

    I need something that's pretty stupid proof. I can figure out how to put all the commands in, but every guide I've used has led me straight to failure. I just don't got it.

    Thanks for any help you can provide.

  • #2
    Originally posted by JooJooBean View Post
    Okay, I've been trying to do it all by myself, and I've been failing miserably when the directions make it stupid-proof.

    Well, I've broken the stupid-proofness.

    Anyway, I have the HD 4670. I know there's radeon and radeonhd. I've read guides saying to install radeon. I've done the ppas, tried installing through the git, and compiling. Heck, I don't even know what I'm really talking about. At the end of the day, I've been getting the black screen of death over and over.

    My linux-kernel is the latest that's out though. I did that right, at least.

    Two weeks ago, I managed to get radeonhd to work. I had no compiz support or any other desktop features, and then I randomly had blue lines going vertically across my screen, whether I'm booting or in gnome. I heard updating to 2.6.33-rc3 fixes that, but nothing has changed on my end.

    So the question. What guide should I follow. Should I keep trying to use radeon, or should I just go back ahead and put radeonhd back on? And which instructions should I follow so that I'm not constantly fixing my xorg and starting over?

    I need something that's pretty stupid proof. I can figure out how to put all the commands in, but every guide I've used has led me straight to failure. I just don't got it.

    Thanks for any help you can provide.
    the easyest way to get mesa7.7+radeon is to install the ubuntu lucid alpfa!

    the easyest way to get mesa7.8+kms+ogl2 is to install xorg-edgers to the ubuntu lucid 10.04!

    Comment


    • #3
      Okay, so I got things up and running.

      Only problem is, I have blue noise all over my screen. It wasn't like this when I put the card in the machine and got it up and working the first time. Then, suddenly, I have 4 or 5 vertical lines worth of blue noise. Goes away when I put a mouse over it, but whenever I'm looking at something black, I see nothing but the blue pixel noise. Kind of annoying.

      I know it's the card. I put other monitors on and I get the same problem.

      Happens on boot up now too.

      Any fix for that? Something wrong with my card?

      Comment

      Working...
      X