Announcement

Collapse
No announcement yet.

[R580] X1900gt direct rendering no

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [R580] X1900gt direct rendering no

    but the 3d works correctly, for example running teeworlds...

    [fabio@abuarch ~]$ glxinfo | grep rendering
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    [fabio@abuarch ~]$

    here the log:

    http://nopaste.info/29690a88d6.html

  • #2
    I didn't see any obvious problems in your log. It wouldn't hurt to try EXA acceleration instead of XAA, but I don't think that is your problem. Is there any chance you have leftover bits from fglrx, specifically libgl ?

    What do you get from LIBGL_DEBUG=verbose glxinfo ? Can you pastebin that ?

    Comment


    • #3
      sure, maybe you get the problem.

      http://pastebin.com/m11b19d51

      Comment


      • #4
        Your libGL.so.1.2 library is looking for the DRI driver in /usr/X11R6/lib64/modules/dri/ but you have it installed in /usr/lib/xorg/modules/dri/ (which is where your X server wants it for AIGLX). You could force libGL.so.1.2 to look in /usr/lib/xorg/modules/dri by setting the LIBGL_DRIVERS_DIR environmental variable to /usr/lib/xorg/modules/dri/ . Ideally, though, your X server and GL library would look in the same place, and this is something that your distributions packages should have done properly. Did you happen to build Mesa from source?

        Comment


        • #5
          Originally posted by adamk View Post
          Your libGL.so.1.2 library is looking for the DRI driver in /usr/X11R6/lib64/modules/dri/ but you have it installed in /usr/lib/xorg/modules/dri/ (which is where your X server wants it for AIGLX). You could force libGL.so.1.2 to look in /usr/lib/xorg/modules/dri by setting the LIBGL_DRIVERS_DIR environmental variable to /usr/lib/xorg/modules/dri/ . Ideally, though, your X server and GL library would look in the same place, and this is something that your distributions packages should have done properly. Did you happen to build Mesa from source?
          absolutely not, I'm using Archlinux right now...

          Comment


          • #6
            the error disappear but:
            http://pastebin.com/m7625f282

            maybe this bug?
            http://bugs.archlinux.org/task/17638

            Comment

            Working...
            X