Announcement

Collapse
No announcement yet.

Bad 2D performance with r600

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad 2D performance with r600

    Lately I'm experiencing a terrible 2D performance in VirtualBox and some other things (for example, the videos in NBA.com). Everything is unbearably choppy and the CPU usage is 100% in one core. These things used to work great not long ago, but even if I downgrade mesa (the usual suspect) to 7.7 I still get a bad performance. So before I start downgrading other packages (in gentoo it's a PITA) I'd like to know if someone else experienced this.

    I'm using the latest git radeon and mesa, libdrm-2.4.17, xorg-server-1.7.3.902, kernel 2.6.32. This is with a rv670 card.

    3D works as good as always, and I have direct rendering enabled. Xorg.0.log also seems normal: http://pastebin.com/m277d1a9b

    (edit)

    Doh, nevermind my VirtualBox problems, I've discovered the bad performance was caused by enabling nested paging . So the only problem seems to be some flash videos, and we all know how well flash works in linux. Nothing to see here.
    Last edited by Fran; 12-30-2009, 04:59 AM.

  • #2
    mesa is responsible for opengl only, 2d acceleration would be the job of your xorg driver (radeon / radeonhd). Just so you can downgrade the correct package if the problem arises again

    Originally posted by Fran View Post
    downgrading other packages (in gentoo it's a PITA)
    echo '>media-libs/mesa-7.7' >>/etc/portage/package.mask
    emerge -avuDNt world
    Last edited by rohcQaH; 12-30-2009, 05:17 AM.

    Comment


    • #3
      Originally posted by Fran View Post
      So the only problem seems to be some flash videos, and we all know how well flash works in linux. Nothing to see here.
      Yeap, proprietary Flash is accelerated over OpenGL so situation might eventually improve. If you can find an open Flash that uses XVideo, it'd likely go smoother.

      Comment

      Working...
      X