No announcement yet.

need big help w/RV740 issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    No, this is a PCI-E 16x card. I'm not too concerned about the 3d stuff.

    edit: I tried radeonhd, I'm guessing it doesn't support my card at all because it dumped me to VT1. When going to change back I thought I'd comment out the EXA and DRI options, but doing so had no apparent effect - going to try setting them to "off" instead, presumably they default to on just like DMAforXv?

    edit2: silly me, you can't set "AccelMethod" to off! And disabling DRI, while getting rid of the corruption, only serves to bring me back to square one with no video.

    edit3: seems there's still a teency bit of corruption even without DRI. So far only seen on the row of 5 icons at the bottom of the Kmenu.

    edit4(a day later): Well, I managed to bend fglrx mostly to my will, though I did curse its existence loudly and repeatedly before reaching that point. It's still not exactly what I'd like, but it's close enough to live with until my card is better supported by the xorg driver. Still interested in a solution to this corruption though.

    Anyway, thanks for your help bridgman, agd5f.
    Last edited by oblivious_maximus; 12-24-2009, 04:16 PM.


    • #12
      I'm posting this just in case this helps to get it fixed, as I have the same card (Sapphire HD4770 PCI) and can confirm that I see the same problem with the radeon drivers that came with Ubuntu 9.10. The fglrx drivers (again default ubuntu ones) are still affected to some degree, but for me much less than the radeon ones. The corruptio appears to affect qt apps much more than GTK ones. I filed a bug report about this:


      • #13
        Following a comment in the launchpad link to another thread on phoronix (, I can confirm that that setting Option "EXANoDownloadFromScreen" "true" in Section "Device" of xorg.conf fixes / works round the screen corruption.


        • #14

          philh, thanks for the tip. I used to think that desktop effects were pointless eye candy that would slow down my system, but once I got the 3D running on my RV710, I found that compositing (Compiz/KWin/xfce4-compositor) ran smoothly, and I really liked it. I hope you find the same.