Announcement

Collapse
No announcement yet.

Radeon DRM Power Management Moves Along

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    These patches do apply, but during kernel compilation they block depmod (without patches all compilation work).
    INSTALL /home/yimm/compilation/kernel-pm-patches/pkg/lib/firmware/radeon/RV730_me.bin
    INSTALL /home/yimm/compilation/kernel-pm-patches/pkg/lib/firmware/radeon/RV710_pfp.bin
    INSTALL /home/yimm/compilation/kernel-pm-patches/pkg/lib/firmware/radeon/RV710_me.bin
    DEPMOD 2.6.33-rc4-rc
    And nothing...
    Ideas?

    Comment


    • #12
      Patches can not block depmod. Just wait longer for it to finish.

      Comment


      • #13
        But I have already waited 15 minutes, and always at the same step; Without them, it takes 1-2 seconds
        So I will retry by waiting more time.
        Last edited by yimm; 01-19-2010, 09:00 AM.

        Comment


        • #14
          First patch is already in drm-radeon-testing.

          How to check if it really downclok the gpu/memory?
          ## VGA ##
          AMD: X1950XTX, HD3870, HD5870
          Intel: GMA45, HD3000 (Core i5 2500K)

          Comment


          • #15
            Originally posted by darkbasic View Post
            First patch is already in drm-radeon-testing.

            How to check if it really downclok the gpu/memory?
            cat /sys/kernel/debug/dri/0/radeon_pm_info

            Comment


            • #16
              Groan... I forgot to enable kernel debugging :-(
              ## VGA ##
              AMD: X1950XTX, HD3870, HD5870
              Intel: GMA45, HD3000 (Core i5 2500K)

              Comment


              • #17
                I enabled kernel debugging but /sys/kernel/debug/ is still empty.
                ## VGA ##
                AMD: X1950XTX, HD3870, HD5870
                Intel: GMA45, HD3000 (Core i5 2500K)

                Comment


                • #18
                  mount -t debugfs none /sys/kernel/debug/

                  Comment


                  • #19
                    gentoo niko # cat /sys/kernel/debug/dri/0/radeon_pm_info
                    state: PM_STATE_DISABLED
                    default engine clock: 776000 kHz
                    current engine clock: 769500 kHz
                    default memory clock: 1126000 kHz
                    current memory clock: 1125000 kHz

                    Then I loaded nexuiz after typing:

                    gentoo niko # sleep 60 && cat /sys/kernel/debug/dri/0/radeon_pm_info
                    state: PM_STATE_DISABLED
                    default engine clock: 776000 kHz
                    current engine clock: 769500 kHz
                    default memory clock: 1126000 kHz
                    current memory clock: 1125000 kHz

                    Clocks are still the same.
                    Anyway, how to change the state? What's PM_STATE_DISABLED?
                    ## VGA ##
                    AMD: X1950XTX, HD3870, HD5870
                    Intel: GMA45, HD3000 (Core i5 2500K)

                    Comment


                    • #20
                      Originally posted by darkbasic View Post
                      gentoo niko # cat /sys/kernel/debug/dri/0/radeon_pm_info
                      state: PM_STATE_DISABLED
                      default engine clock: 776000 kHz
                      current engine clock: 769500 kHz
                      default memory clock: 1126000 kHz
                      current memory clock: 1125000 kHz

                      Then I loaded nexuiz after typing:

                      gentoo niko # sleep 60 && cat /sys/kernel/debug/dri/0/radeon_pm_info
                      state: PM_STATE_DISABLED
                      default engine clock: 776000 kHz
                      current engine clock: 769500 kHz
                      default memory clock: 1126000 kHz
                      current memory clock: 1125000 kHz

                      Clocks are still the same.
                      Anyway, how to change the state? What's PM_STATE_DISABLED?
                      You have to enable it using dynpm parameter (dynpm=1). You can set this on loading module time (modprobe radeon dynpm=1), or in GRUB (radeon.dynpm=1) or in /etc/modprobe.d/some.file

                      Comment

                      Working...
                      X