Announcement

Collapse
No announcement yet.

Mesa git and New libdrm 2.4.15 Requirement..

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mesa git and New libdrm 2.4.15 Requirement..

    I've been tracking mesa git, and recently, ran afoul of this commit:
    http://cgit.freedesktop.org/mesa/mes...a090a9f37e7c05

    Since I'm using agd5f's DRM (2.4.3), I had to change the configure.ac file back to 2.4.3 to get Mesa to build. So far, everything seems okay. Do you think not having a more recent libdrm will have any effect on using the R600 DRI driver with a 2.6.31 kernel? (on an RV710 with no KMS) Thanks.

  • #2
    Originally posted by DanL View Post
    I've been tracking mesa git, and recently, ran afoul of this commit:
    http://cgit.freedesktop.org/mesa/mes...a090a9f37e7c05

    Since I'm using agd5f's DRM (2.4.3), I had to change the configure.ac file back to 2.4.3 to get Mesa to build. So far, everything seems okay. Do you think not having a more recent libdrm will have any effect on using the R600 DRI driver with a 2.6.31 kernel? (on an RV710 with no KMS) Thanks.
    You can still use the modules from agd5f/drm/linux-core with libdrm from mesa/drm.

    Comment


    • #3
      I was hoping someone would post this question. I thought about changing the drm config.ac file to that required but didn't do it yet. Good to know it, or the similar change in mesa should work. Any other responses?

      Comment


      • #4
        The newer libdrm is only required for intel.

        Comment

        Working...
        X