No announcement yet.

Sudden massive performance increase, radeon/ati

  • Filter
  • Time
  • Show
Clear All
new posts

  • Sudden massive performance increase, radeon/ati

    Hey all,

    Odd question I know, but after todays bath of upgrades to my Arch system, which included an upgrade to, and ATI driver 6.12.4.

    Previously, I got around 3000fps on glxgears with my X1900XTX, now I get just shy over 5000. Meaningless figure as 3000 is more than enough!

    But, Firefox is suddenly rediculously snappy, I close a browser tab and immediately see the tab to the right on screen. Youtube videos play smoothly, in HD!

    My load average is currently 0.00 rather than over 1 or even 2, thats with Firefox running with too many tabs for my own good and Spotify streaming.

    Is this performance increase related to the xf86-video-ati driver, or something unrelated? I've disabled KMS for the timebeing while waiting for dri etc 7.6 to be pushed to the Arch repo's, but this massive performance increase in the meantime is most welcome!

  • #2
    The same thing happened for me using the radeonhd driver on Ubuntu Jaunty. I know glxgears isn't a good benchmark, but I always got ~1000 fps before I updated Mesa, DRM, and the radeonhd driver the other day. Now it's ~1800fps.


    • #3
      Last I tried the RadeonHD driver it was slower on both my X1900XTX and X1200 laptop, in comparison to Radeon. I even went to the trouble of compiling the driver, mesa, dri, drm etc from git only for my system to hard lock a few seconds after enabling compositing

      It's not hugely important, but I'd love to know what has changed which has caused such a massive performance increase. All along I've been blaming Firefox for slowing my system down, but now it is performing faster than even in Windows. Pages even render faster, presumably due to much lower load levels than before, my system being based on a 2.5GHz dual core Opteron.

      I can't get over being able to play flash videos in HD, though full screen is still too much to ask!

      I'm hoping that once Mesa 7.6 etc is pushed to Arch, KMS will work correctly and I'll be able to have a full res fb...and maybe even more performance


      • #4
        It might be because you went back to non-KMS. I've found KMS hurts performance a lot, especially in Firefox. There seem to be some major EXA issues that cause Firefox to be exceptionally slow with KMS/DRI2 compared to DRI.

        3d apps aren't nearly as big of a decrease but I did see some decrease with glxgears and Quake Live also. For now I'm still using KMS though as I'm sure this will improve with time.


        • #5
          I have a similar system and I'm running Ubuntu 9.10 beta. Pentium D 3.20Ghz, x1900xtx. I am running with KMS though.

          Glxgears runs at 10,000 frames. Real world performance is the same as you described though. HD Youtube vids play fine except in fullscreen.

          I haven't payed attention to non-KMS performance as I've just got Linux back on my system.

          It seems there has been a lot great work coming out of the graphics department lately. Yay devs!
          Last edited by rob2687; 10-11-2009, 01:19 AM.


          • #6
            As far as I am aware, KMS has only been running on my machine since yesterday, when I upgraded to Before this upgrade, 3d worked fine, with glxgears at around 3000fps, Firefox was sluggish, which I thought was normal!
            Upgraded to, KMS enabled by default, and lost DRI due to a version mismatch, as presumably it was trying to use DRI 2.0.0 which is currently unsupported by MESA 7.5.
            Disabled KMS which got 3d working again, with the huge increase in application performance and glxgears hitting over 5000fps.

            rob, how do you get 10000fps, with a Pentium D and the same card as me. I don't really know Intel CPU's all that well, but isn't a Pentium D slower than the Core 2 etc?


            • #7
              Are you sure this is not more related to a Firefox upgrade? I'm noticing a much snappier browser since I installed 3.5 (3.5.3 in Debian Sid). Now I got used to it but I remember being surprised at its responsiveness and faster rendering right after the upgrade.


              • #8
                Yep, I've got the same build of Firefox, 3.5.3, built mid September.
                Other apps feel faster, but Firefox is most noticeable.
                My system load average is also much lower, barely exceeding 0.05 even when playing Youtube videos...previously my load average was above 1 all the time while Firefox was running...While Firefox was running, it was using a lot of CPU, as was X and Plasma. Close firefox, and X/Plasma would drop in CPU usage dramatically, though not as much as it has done now.

                I'm not doubting Firefox 3.5 is an improvement, as I did see an improvement when I switched to it. But, it's now like night and day, switching tabs is instant, pages render quicker. Quite happy with it, have just thought it's how it is!


                • #9
                  I'm not sure, but I think the problem with Firefox is because it uses the XUL crap. With the intel drivers I had problem with DRI2 and Firefox, it was the only apps that was so text intensive. It mad everything so slow.


                  • #10
                    its not because firefox uses XUL, but rather because firefox uses XRender heavily which is still flaky with some drivers...