Announcement

Collapse
No announcement yet.

[Radeon + KMS + Karmic + X1400] Screen blanks out once in a while

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Radeon + KMS + Karmic + X1400] Screen blanks out once in a while

    Hi

    I'm using latest Karmic Build with the Xorg-Edgers PPA
    everything's working fine, compiz, 3D games... but
    my screen gets black for 1 sec sometimes, mostly while watching videos
    oder playing 3D games, on normal Desktop usage, even with compiz enabled,
    everything's ok. when it goes black, it looks a bit like shutting off an old crt monitor. Im using a Dell G2410 Monitor via DVI with the Dockingstation of my Thinkpad.
    Does anybody know why this is happening, or better how to resolve it?

    greetings from germany

    killigrew

  • #2
    Sounds like a display underflow issue. The DisplayPriority option needs to be ported to kms. To test it you can disable kms and add:
    Option "DisplayPriority" "HIGH"
    to the device section of your config.

    Comment


    • #3
      Hi

      didn't help, with kms, without kms and with DisplayPriority High, alway the same Problems.

      Comment


      • #4
        are you using Ubuntu Karmic? Check System->Einstellungen->Energieverwaltung.

        Comment


        • #5
          Hi, no, that was not the solution.
          When I start crrcsim (an RC Plane Simulator) the screen goes black completely and comes back on only after shutting down the game via alt+F4.

          Comment


          • #6
            Originally posted by Killigrew View Post
            Hi, no, that was not the solution.
            When I start crrcsim (an RC Plane Simulator) the screen goes black completely and comes back on only after shutting down the game via alt+F4.
            Sounds like program could be using Direct color visual which is known to be buggy. Can you change it to use double buffering from config?

            Comment


            • #7
              The problem occures only if the monitor is connected via dvi.
              Via vga there is no flickering or anything at all.

              Comment


              • #8
                Sounds familiar...

                https://bugzilla.redhat.com/show_bug.cgi?id=501601

                Even clean fedora 11 without fancy KMS stuff suffers this.


                Originally posted by Killigrew View Post
                Hi

                I'm using latest Karmic Build with the Xorg-Edgers PPA
                everything's working fine, compiz, 3D games... but
                my screen gets black for 1 sec sometimes, mostly while watching videos
                oder playing 3D games, on normal Desktop usage, even with compiz enabled,
                everything's ok. when it goes black, it looks a bit like shutting off an old crt monitor. Im using a Dell G2410 Monitor via DVI with the Dockingstation of my Thinkpad.
                Does anybody know why this is happening, or better how to resolve it?

                greetings from germany

                killigrew

                Comment


                • #9
                  Hi

                  yes, some of the description are looking familiar indeed

                  greetings, and thanks for your afford
                  Last edited by Killigrew; 09-22-2009, 05:49 PM.

                  Comment

                  Working...
                  X