Announcement

Collapse
No announcement yet.

Survey on high priority Radeons bugs -> 2009-10-29

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Survey on high priority Radeons bugs -> 2009-10-29

    Ubuntu 9.10 is scheduled on 2009-10-29 and currently is shipping kernel 2.6.31 without radeon KMS support, a git snapshot of -ati driver 6.12.99 and a git snapshot of mesa 7.6.

    What are your high priority bugs you would like to see fixed as soon as possible (and in final release of Ubuntu 9.10 if you are an Ubuntu user)? This includes 2D and 3D, but excludes experimental, disabled by default, features like KMS/DRI2/Power savings/R600+ 3D and so on. I hope that doing this little survey could help developers in knowing which bugs are the most annoying for end users and maybe focus on them.

    Actually I am quite satisfied with both 2D and 3D on my RV530, the only bugs I'd like to see fixed are:

  • #2
    Actually I am facing a serious "address space collision" bug that prevents me from making a fresh install of karmic (alpha5) and even jaunty. The screen stays black and only the cursor is visible.
    From what I can tell, it's due to the 64M AGP aperture not handled well, and may be even a regression since it was ok with hardy.
    I'd appreciate if the devs could check out the history and logs I put in the bug report linked below and at least reply if it's a radeon bug or a kernel bug

    https://bugs.launchpad.net/ubuntu/+s...ti/+bug/368187

    The bug has been open for some months and I hope it can be solved before 9.10 final.

    Thanks again for the great work!

    Comment


    • #3
      Thanks for the TexSubImage crash reminder. This should really be investigated - I just keep running into issues when trying to reproduce it :/

      Comment


      • #4
        http://bugs.freedesktop.org/show_bug.cgi?id=23901

        :-)

        Comment


        • #5
          Originally posted by nhaehnle View Post
          Thanks for the TexSubImage crash reminder. This should really be investigated - I just keep running into issues when trying to reproduce it :/
          Let me know if I can be of help reproducing it (I am the original bug reporter) .

          Comment


          • #6
            Originally posted by pvautrin View Post
            The screen stays black and only the cursor is visible.
            I have the same problem on Mandriva 2010 test releases. I got around it by going to a terminal (Ctrl+Alt+F1), becoming root then typing killall X. X instantly rebooted and everything was fine.
            A few people on the Mandriva forums had this or similar issues.

            In case it matters I'm running a Radeon X1950 Pro (RV570) PCI-E card.

            Comment


            • #7
              http://www.phoronix.com/forums/showthread.php?t=19179

              Comment


              • #8
                I'm hoping for R700 + working KMS power management soon. Not worried about what happens to Ubuntu 9.10 since I run git versions anyway.

                I had to reinstall a bunch of stuff yesterday because of a library messup that left most of my X apps unusable, so I'd left my PC running overnight on VT1. Came back, started X and xfce-sensors was showing me a red bar of death for the case temp

                Comment


                • #9
                  I've been having trouble getting 6xx/7xx 3D running on Karmic, even with fresh radeon/mesa/drm. Does anyone have 6xx/7xx non-KMS 3D running on current Karmic ? Current thinking is that maybe the drm code is built into the kernel which prevents a new drm from working without a kernel rebuild... trying to confirm that now.

                  Comment


                  • #10
                    Originally posted by bridgman View Post
                    I've been having trouble getting 6xx/7xx 3D running on Karmic, even with fresh radeon/mesa/drm. Does anyone have 6xx/7xx non-KMS 3D running on current Karmic ? Current thinking is that maybe the drm code is built into the kernel which prevents a new drm from working without a kernel rebuild... trying to confirm that now.
                    Yeah, I have it running. See: http://ubuntuforums.org/showthread.php?t=1257453

                    Comment


                    • #11
                      Ah yes, looks like the Intel KMS drm is still being loaded automatically even if you're running with non-Intel graphics. Blacklisting the Intel drivers and updating the initramfs then rebooting allowed the drm to start properly and then everything worked. Thanks !

                      EDIT - just remembered something -- I noticed you mentioned that Google Earth wasn't working well -- it seems to run fine if you run it from the command line with vblank_mode=0.
                      Last edited by bridgman; 09-16-2009, 03:20 PM.

                      Comment


                      • #12
                        For many people includign me, with R6xx+, Ubuntu 9.10 doesn't work at all at the moment.

                        https://bugs.launchpad.net/ubuntu/+s...ti/+bug/419126

                        Comment


                        • #13
                          Originally posted by d2kx View Post
                          For many people includign me, with R6xx+, Ubuntu 9.10 doesn't work at all at the moment.

                          https://bugs.launchpad.net/ubuntu/+s...ti/+bug/419126
                          They shouldn't be shipping the r600 3D driver without the proper drm bits.

                          Comment


                          • #14
                            You mean mesa?

                            Comment


                            • #15
                              Mesa built with "r600" included in the --with-dri-drivers= option string...

                              ... might be easier/better to patch in the r600 drm bits.

                              Comment

                              Working...
                              X