Announcement

Collapse
No announcement yet.

R600/r700 kms + 3d dri1/dri2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by tormod View Post
    xorg-edgers for lucid is under construction, please just wait until we open it for general consumption
    OOps! I've been drinking water from that pipe "under construction" for a couple of days already ... Silly me ... Is there a medicine ... ? Please keep the good work, constructing it, on. I'll wait ...

    Give us a wink when the construction is finished.
    Last edited by zika; 11-11-2009, 02:36 PM.

    Comment


    • Originally posted by zika View Post
      OOps! I've been drinking water from that pipe "under construction" for a couple of days already ... Silly me ... Is there a medicine ... ? Please keep the good work, constructing it, on. I'll wait ...

      Give us a wink when the construction is finished.
      Thanks for your early feedback anyway and for smoketesting the first builds before we got a chance to do it ourselves Spotted a few things there which saved me from some trial and error.

      Thanks to Sarvatt's hard day's night of uploading we can now turn open the firehose again! A normal apt-get dist-upgrade should do the job. Only all the less-used drivers which we haven't bothered to rebuild for 1.8 yet will be removed.

      Comment


      • Originally posted by tormod View Post
        Thanks for your early feedback anyway and for smoketesting the first builds before we got a chance to do it ourselves Spotted a few things there which saved me from some trial and error.

        Thanks to Sarvatt's hard day's night of uploading we can now turn open the firehose again! A normal apt-get dist-upgrade should do the job. Only all the less-used drivers which we haven't bothered to rebuild for 1.8 yet will be removed.
        I'll try it right now and report if any errors occur.
        Update: It worked! I've got my screen back after reboot (not needed, I just wanted to be sure ...) Thank You!
        Last edited by zika; 11-11-2009, 03:40 PM.

        Comment


        • Tonight's upgrades of mesa and xorg-xserver-video-ati are great! It almost doubled the speed in KMS and it's fast without it as it was not in near past ... Great!

          Comment


          • After today's upgrade KMS is as fast as non-KMS (2.6.32-6.8 is running, for the fist time, KMS as a default). Great!

            Comment


            • How are you measuring the improvement?

              Comment


              • Originally posted by pingufunkybeat View Post
                How are you measuring the improvement?
                With GtkPerf ...

                Comment


                • Should I worry about:
                  Code:
                  ~$ dmesg|grep radeon
                  [    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-999-generic root=UUID=2c53f5b7-8d17-47c7-a450-5544c483596e ro radeon.modeset=1
                  [    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-999-generic root=UUID=2c53f5b7-8d17-47c7-a450-5544c483596e ro radeon.modeset=1
                  [   13.107200] [drm] radeon kernel modesetting enabled.
                  [   13.107324] radeon 0000:01:00.0: setting latency timer to 64
                  [   13.109378] [drm] radeon: Initializing kernel modesetting.
                  [   13.111962] [drm] radeon: 256M of VRAM memory ready
                  [   13.111965] [drm] radeon: 512M of GTT memory ready.
                  [   13.112028] radeon 0000:01:00.0: irq 28 for MSI/MSI-X
                  [   13.112034] [drm] radeon: using MSI.
                  [   13.112059] [drm] radeon: irq initialized.
                  [   13.112654] platform radeon_cp.0: firmware: requesting radeon/RV635_pfp.bin
                  [   13.144865] platform radeon_cp.0: firmware: requesting radeon/RV635_me.bin
                  [   13.158755] platform radeon_cp.0: firmware: requesting radeon/R600_rlc.bin
                  [   13.161712] r600_cp: Failed to load firmware "radeon/R600_rlc.bin"<----------------------this!
                  [   13.161729] radeon 0000:01:00.0: ffff8800b0612e00 unpin not necessary
                  [   13.161732] radeon 0000:01:00.0: ffff8800b0612800 unpin not necessary
                  [   13.161735] radeon 0000:01:00.0: ffff8800b0612e00 unpin not necessary
                  [   13.161738] radeon 0000:01:00.0: ffff8800b0612e00 unpin not necessary
                  [   13.347453] fb0: radeondrmfb frame buffer device
                  [   13.347460] [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
                  ?
                  Last edited by zika; 12-12-2009, 09:46 AM.

                  Comment


                  • Originally posted by zika View Post
                    Should I worry about:
                    Code:
                    [   13.161712] r600_cp: Failed to load firmware "radeon/R600_rlc.bin"
                    This is the interrupt controller microcode/firmware:
                    http://www.mail-archive.com/dri-deve.../msg45005.html
                    http://www.phoronix.com/scan.php?pag...item&px=Nzc1MQ
                    Last edited by tormod; 12-12-2009, 11:54 AM.

                    Comment


                    • Originally posted by tormod View Post
                      Thank You very much! Second URL have those file already assembled and I've put them in /lib/firmware/radeon (after creating radeon folder)... Error is now gone ...
                      Update:Error is gone but the graphics became very erratic at boot. I removed that folder, got the error again but very stable and fast graphics with 2.6.32-999 is back.
                      Last edited by zika; 12-12-2009, 06:55 PM.

                      Comment

                      Working...
                      X