Announcement

Collapse
No announcement yet.

HD4770: Screen corruption and artefacts with the from-git graphical stack

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HD4770: Screen corruption and artefacts with the from-git graphical stack

    Hi,

    I have had corruption problems with the open source driver for a few days now and it doesn't seem to go away.

    Here is a video of the current state on my computer:
    http://mupuf.org/blog/article/10/

    Do you guys have any idea of what's going on ?

    Thanks a lot

  • #2
    Are you running openarena with LIBGL_ALWAYS_INDIRECT=yes ? It will look pretty bad if you don't right now...

    Comment


    • #3
      Also, EXA DFS seems to have issues on some rv740s.
      Option "EXANoDownloadFromScreen"
      should fix any issues with the cursor or small pixmaps.

      Comment


      • #4
        Thanks to both of you! It works quite well.
        There are still some minor corruption problems when typing text for example but I can live with it

        Comment


        • #5
          Originally posted by MPF View Post
          Thanks to both of you! It works quite well.
          There are still some minor corruption problems when typing text for example but I can live with it
          I have the same issues with compiz enabled.


          I hope this is a known bug and not Arch related, since I am using the same packages as MPF.

          Comment


          • #6
            Perry3D: Did you activate Option "EXANoDownloadFromScreen" ?
            It solved my problems and I no longer have this kind of corruption.

            Comment


            • #7
              Yes, i already tried this option: no difference.
              The corruptions appears when typing text, opening the gnome menu and some progress bars:

              Comment


              • #8
                Originally posted by Perry3D View Post
                I have the same issues with compiz enabled.

                I hope this is a known bug and not Arch related, since I am using the same packages as MPF.
                Yes, this is a known issue.

                Comment


                • #9
                  Speaking of corruption, after upgrading to KDE 4.3, all the XRender-related artefacts disappeared and compositing in XRender mode is working great (though seemingly a bit slower than before).

                  OpenGL compositing starts, but hangs after a while.

                  Comment


                  • #10
                    I'd just like to chime in and say that EXANoDownloadFromScreen fixed the pointer corruption issues I was having in Gnome as well (no compositing, Ubuntu 9.04 w/ git drm/mesa/xorg-driver).

                    My card is a Radeon HD 4770 on a Gigabyte 785G-based mATX motherboard.

                    I'm still getting glxgears corruption with both normal GL, and with LIBGB_ALWAYS_INDIRECT=1, but I won't be able to do much troubleshooting with that until after work probably.

                    Comment


                    • #11
                      any one knows a ppa with latest code for ati r7xx oss driver for ubuntu karmic?

                      Comment


                      • #12
                        Originally posted by jrch2k8 View Post
                        any one knows a ppa with latest code for ati r7xx oss driver for ubuntu karmic?
                        https://launchpad.net/~xorg-edgers/+archive/ppa for user space parts.

                        Too bad kernel modules aren't anywhere so you have to compile them like told in wiki radeon build how to

                        Comment


                        • #13
                          thx ill try tonigth

                          Comment


                          • #14
                            ok drm/xv/exa working nicely but again

                            radeon 4850x2 ID is 0x9443

                            this pciid is still missing in drm and mesa 7.6 today git

                            Comment


                            • #15
                              added the missing id.

                              Comment

                              Working...
                              X