No announcement yet.

3D + RandR dual screen = no-go ?

  • Filter
  • Time
  • Show
Clear All
new posts

  • 3D + RandR dual screen = no-go ?

    I'm trying to get 3D going with a HD3870 using radeonhd with the driver, drm modules and mesa built from git sources following the xorg wiki instructions. I'm on Gentoo using kernel 2.6.30.

    I have a dual screen setup and when I first tried to get 3D working and couldn't I just shrugged it off as having done something wrong and thought I'd try again some time in the future.. but then I was messing around with my xorg config and managed to break my uber cool randr dual screen setup and behold, 3D was suddenly working - until I fixed my xorg conf to get rid of the awful clone mode.

    So.. is it supposed to work when I have two monitors set up using randr and if yes where to start looking for the problem..

    In KDE 4.2 when I enable desktop effects, I get kicked back to kdm. I log back on and desktop effects is enabled in the menus but isn't working. Using just one monitor or clone mode, it works (with corruption but still). Google Earth just shows pitch black where the sweet 3D action should be.

    Glxgears, however, works just fine.

    Mesa: CPU vendor: AuthenticAMD
    Mesa: CPU name: AMD Processor model unknown
    Mesa: Mesa 7.6-devel DEBUG build Aug 20 2009 19:18:55
    Mesa warning: couldn't open, software DXTn compression/decompression unavailable
    IRQ's not enabled, falling back to busy waits: 2 16
    Mesa: MMX cpu detected.
    Mesa: 3DNow! cpu detected.
    Mesa: SSE cpu detected.
    Mesa: Not testing OS support for SSE, leaving enabled.
    no rrb
    9054 frames in 5.0 seconds = 1810.728 FPS
    9112 frames in 5.0 seconds = 1822.372 FPS
    I've always sucked at making a xorg config file so most likely I just messed it up somehow.. here it is:

    Section "Monitor"
            Identifier   "BenQ"
            Option       "PreferredMode" "1920x1080"
    Section "Monitor"
            Identifier   "Acer"
            Option       "RightOf" "BenQ"
            Option       "PreferredMode" "1280x1024"
    Section "Device"
            Identifier  "3870"
            Driver      "radeonhd"
            Option      "monitor-DVI-I_1/digital" "BenQ"
            Option      "monitor-DVI-I_2/digital" "Acer"
            Option      "RROutputOrder" "BenQ"
            Option      "AccelMethod" "exa"
            Option      "DRI" "on"
    Section "Screen"
            Identifier "MyScreen"
            Device     "3870"
            DefaultDepth     24
            SubSection "Display"
                    Depth     24
    Section "DRI"
            Mode    0666
    My xorg log can be found at and glxinfo at

    any other information and/or logs you want to see, ask and I shall try to provide..


  • #2
    Just tried Neverball and it works perfectly so it seems to be a bit selective what works and what doesn't.


    • #3

      I have dual screens on KDE 4.3. KDE crashes when I enable OpenGL desktop effects, but when I log back in it works but with corruption.