Announcement

Collapse
No announcement yet.

Has anyone got KMS (or any of the new bits) working on R200 yet?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Has anyone got KMS (or any of the new bits) working on R200 yet?

    I tried over the weekend with no success; installed everything straight from git - mesa 7.6, xserver 1.7, kernel 2.6.31-rc5, and x-v-ati.

    So far I've managed to break () the following and was wondering what should be expected at the moment:
    1. KMS doesn't actually work. The kernel log says "modesetting enabled by default", but then the X log says it's disabled.
    2. DRI doesn't work when modesetting is turned on. The /dev/dri/card0 file actually disappears, even though the kernel log says DRI is loaded. Messing around with the agpmode parameter as suggested in the Ubuntu thread doesn't seem to affect this.
    3. With KMS off & DRI on, I get crashes in UT2004 when it tries to load a level. The intro has 3D bits that work fine, though.
    4. 2D speed has evaporated completely. Some things seem OK, other things like mouse hover effects on gtk buttons lag for up to a second. Nothing in the X log suggests anything is wrong, it says EXA is enabled and everything...

    This is using all stuff from the gentoo X11 overlay. I tried flipping on/off various likely-sounding Use flags but didn't get anywhere.

  • #2
    Your list is missing libdrm. ^^ Hope you haven't forgotten it though.
    (more specifically libdrm from git master compiler with --enable-radeon-experimental-api)

    Comment


    • #3
      The libdrm ebuild forces that switch (and the nouveau one) on already. I should probably mention there's a "gallium" option on the mesa ebuild, but it seems to have no effect either on or off.

      Comment


      • #4
        Yeah, enabling Gallium doesn't matter since classic Mesa is used by default in any case. Just wondering: do you have radeon module as inbuilt? There were some complications with dri node not getting generated if radeon is inbuilt iirc.

        Comment


        • #5
          Just recompiled it as a module, tried modprobe/rmmod'ing radeon+ttm+drm several times (including drm.debug=1), but nothing (not even an error message)

          Comment


          • #6
            Probably irrelated but you don't have any framebuffer drivers (vesafb, radeonfb or so) loaded, right?

            Comment


            • #7
              That's a good point actually... does radeon KMS have a separate framebuffer driver like the intel one does? Will try that in a minute.

              I found out why my 2D was so slow - in my laziness I'd upgraded everything to git versions without checking; it installed git cairo, and well... it was rendering through Mesa instead. Or something. Downgraded to 1.8.8 and 2D is usable again... for now.

              Comment


              • #8
                Originally posted by nanonyme View Post
                Probably irrelated but you don't have any framebuffer drivers (vesafb, radeonfb or so) loaded, right?
                I'm not sure if that's what his issue is, but removing vesafb (really any FB drivers besides building radeon as a module) was what I needed to do on my laptop a few minutes ago to get things working. That one had me scratching my head for a little while over the last few days.

                Comment


                • #9
                  You were right! Taking radeonfb out got it working.

                  Now let's see if I can get 3D apps to not crash...

                  Comment

                  Working...
                  X