Announcement

Collapse
No announcement yet.

ATI R600/700 OSS 3D Driver Reaches Gears Milestone

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Decided to note it here so it gets documented: if you're having a fullscreen black screen with Fedora 11 when running glxgears with the r600 Mesa driver, try instead running progs/demos/gears from your Mesa build tree. (assuming you compiled the demos) It's the exact same program, just a newer version. It seems Fedora 11 got shipped with a glxgears that features a bit odd with at least this particular driver.
    Last edited by nanonyme; 07-16-2009, 05:18 PM.

    Comment


    • #52
      I don't think this is a Fedora-specific issue - I see the same thing on Ubuntu 9.04.

      Since gears is in progs/demos and glxgears is in progs/xdemos, my thinking was that gears uses direct rendering and glxgears uses GL through X, ie indirect rendering.

      Comment


      • #53
        Originally posted by bridgman View Post
        Since gears is in progs/demos and glxgears is in progs/xdemos, my thinking was that gears uses direct rendering and glxgears uses GL through X, ie indirect rendering.
        Oh, very good notion. The major difference (in terms of what the end-user sees, not in terms of implementation) between the two (Fedora glxgears vs progs/demos/gears, will still have to test the one in xdemos, I guess) is the black screen on some cards, both render just as wrong on r6xx.

        Comment


        • #54
          Alex thinks he might have a fix for 6xx, stay tuned...

          Comment


          • #55
            Originally posted by bridgman View Post
            Alex thinks he might have a fix for 6xx, stay tuned...
            Confirmed, http://cgit.freedesktop.org/mesa/mes...2c9a15cdb2de1c fixes the colour problems in gears, glxgears and hello for me. (still having the black screen in glxgears, aww)

            Comment


            • #56
              I'm trying this tomorrow.

              Anyway, nevermind my comment about libdrm. I just booted the wrong kernel which doesn't have a proper radeon module build, so DRI was disabled.

              Comment


              • #57
                On my rv620 colours seem correct in most apps now except varray. Also getting the black screen in glxgears but not gears. Still getting some corruption in the gears (seems like size is jumping around), seems to happen only when EXA is drawing.

                Anyways, now I can give back the rv770 I borrowed from QA

                Comment


                • #58
                  Sounds good. But here is a stupid question.

                  - glxgears looks like a simple graphictask. So I don't understand why it is a milestone? I mean, isn't there alot of work to be done yet? Or is it really a milestone, because we can say the main 3d-part of the driver is now working, and it now only need prober opengl support?

                  Comment


                  • #59
                    The driver was pretty much fully written in April. We were just starting to bring it up when it became obvious we needed to move it over to the radeon-rewrite code base, which in turn meant that we had to *understand* the radeon-rewrite changes

                    Getting glxgears working means that most of the major blocks of the driver are running, including the shader compiler / assembler (since mesa uses a vertex shader to emulate fixed-function TCL on GPUs that don't have fixed function). Gears doesn't exercise textures at all AFAIK, but it lights up most of the other areas.
                    Last edited by bridgman; 07-16-2009, 07:09 PM.

                    Comment


                    • #60
                      Originally posted by bridgman View Post
                      The driver was pretty much fully written in April. Getting glxgears working means that most of the major blocks of the driver are running, including the shader compiler. Gears doesn't exercise textures at all AFAIK, but it lights up most of the other areas.
                      Aah I see.
                      But I shouldn't try this on a 2.6.30 kernel?
                      Last edited by tball; 07-16-2009, 07:06 PM.

                      Comment

                      Working...
                      X