Announcement

Collapse
No announcement yet.

Radeon 2400

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon 2400

    Dear Phoronix

    I have a Radeon 2400 on a Debian lenny system.

    I seem to have destroyed the file libGL.so.1 recently by uninstalling the ATI Catalyst driver.

    I have now installed:
    xserver-xorg-video-radeon
    xserver-xorg-video-radeonhd

    but am having a few problems.

    Question 1: Which driver is recommended? The radeon or the radeonhd?
    Question 2: How do I determine which driver I'm using now?
    Question 3: The output from "glxinfo" is:

    glxinfo: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

    How can I correct this problem?

    Cheers, Nick

  • #2
    1) Which driver is recommended? The radeon or the radeonhd?
    I don't know. I always try radeon first.

    2) How do I determine which driver I'm using now?
    /var/log/Xorg.0.log will contain information about which driver was initialised. Mine is strewn with messages from RADEONHD

    3) The output from "glxinfo" is [...]:
    libGL.so.1 is likely provided by libgl1-mesa-glx.

    aptitude reinstall libgl1-mesa-glx

    Note that the 2400 doesn't have 3D yet in either radeon or radeonhd, so you'll be rendering in software.

    Comment


    • #3
      Radeon 2400

      Thanks for your help!

      I have reinstalled libgl1-mesa-glx.
      The system can find libGL.so.1 now.

      But output from glxinfo has a different error:

      Xlib: extension "GLX" missing on display ":0.0".
      Xlib: extension "GLX" missing on display ":0.0".
      Xlib: extension "GLX" missing on display ":0.0".
      Error: couldn't find RGB GLX visual

      visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
      id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
      ----------------------------------------------------------------------
      Xlib: extension "GLX" missing on display ":0.0".
      Xlib: extension "GLX" missing on display ":0.0".
      0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
      Xlib: extension "GLX" missing on display ":0.0".
      Xlib: extension "GLX" missing on display ":0.0".
      0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
      Xlib: extension "GLX" missing on display ":0.0".
      Xlib: extension "GLX" missing on display ":0.0".
      0x58 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

      ------------------------

      Sorry, I don't understand what's wrong or how to correct this.

      Comment


      • #4
        It is quite possibly a problem with your /etc/X11/xorg.conf file - what do you have in there?

        It may also help to check for initialisation errors when X loads (grep EE /var/log/Xorg.0.log) - any line starting with (EE) is an error. It might also be worth looking for (WW) for warnings as well.

        Understanding what is going on in the X server is a difficult one, most of the development for the last couple of years has been making it comprehensible rather than adding features, as far as I know. Don't worry, it secretly wants to work.

        Comment


        • #5
          You may need to reinstall xserver-xorg-core package as well.
          https://wiki.ubuntu.com/X/Troublesho...er?action=show

          Comment


          • #6
            Radeon 2400

            My xorg.conf:

            Section "InputDevice"
            Identifier "Generic Keyboard"
            Driver "kbd"
            Option "XkbRules" "xorg"
            Option "XkbModel" "pc105"
            Option "XkbLayout" "gb"
            EndSection

            Section "InputDevice"
            Identifier "Configured Mouse"
            Driver "mouse"
            EndSection

            Section "Device"
            Identifier "ATI 3D"
            Driver "radeonhd"
            EndSection

            Section "Monitor"
            Identifier "Configured Monitor"
            EndSection

            Section "Screen"
            Identifier "Default Screen"
            Monitor "Configured Monitor"
            Device "ATI 3D"
            EndSection

            Section "Module"
            Load "glx"
            Load "dri"
            EndSection

            Section "DRI"
            Mode 0666
            EndSection

            ---------------------------------------

            Does anybody know if it's possible to get direct rendering to work with this driver?

            Comment


            • #7
              Originally posted by DanL View Post
              You may need to reinstall xserver-xorg-core package as well.
              https://wiki.ubuntu.com/X/Troublesho...er?action=show
              Thanks, Dan.

              This troubleshooting guide was very helpful indeed.

              The RADEONHD driver works well. I have supplied my xorg.conf file above. Does this driver support direct rendering? If so, how do I make it work?

              Cheers, Nick

              Comment


              • #8
                Originally posted by sefnyn View Post
                Does this driver support direct rendering? If so, how do I make it work?
                Originally posted by R15I23D05D14Y View Post
                Note that the 2400 doesn't have 3D yet in either radeon or radeonhd, so you'll be rendering in software.

                ------------------------------------------


                About the question radeon or radeonhd. Both drivers support 2d (EXA) and XV for your card. The radeon is nice for Xv (tear free ) and the radeonhd if you want HDMI and HDMI audio.

                Comment


                • #9
                  Originally posted by sefnyn View Post
                  Thanks, Dan.
                  The RADEONHD driver works well. I have supplied my xorg.conf file above. Does this driver support direct rendering? If so, how do I make it work?

                  Cheers, Nick
                  As Nile says 3d is experimental, work is ongoing.
                  If you want XV and EXA with radeonhd you need to add -

                  Option "DRI"
                  Option "AccelMethod" "exa"

                  to the Device section of your xorg.conf

                  Comment

                  Working...
                  X