Announcement

Collapse
No announcement yet.

Anybody else with weird KMS modes on ATI?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anybody else with weird KMS modes on ATI?

    Hi everybody!

    I would like to ask if I am the only one experiencing wrong resolution / refresh detection by ATI KMS:
    https://bugzilla.redhat.com/show_bug.cgi?id=509740#c4

    Maybe this is a bit more difficult because I am using a CRT monitor...

    So, anyone in the same boat?

  • #2
    Now it works.

    Ok, now KMS seems to work much better!
    https://bugzilla.redhat.com/show_bug.cgi?id=509740#c6

    BTW, I'm now wondering how to set resolution when KMS is enabled. "vga=value" doesn't seem to apply to KMS too, so even after googling I'm left in the dark.

    If there is no way to do so it's really a pain: KMS sets my monitor to it's maximum capability 1920x1440@60Hz, which is not good (nor readable, it's a 19" CRT!), instead of the reccomended 1280x1024@100Hz (@85Hz would be fine too).
    I know I can change the XServer resolution, but I also want to use VTs.

    Does anybody know of a way to do so?

    Comment


    • #3
      Originally posted by panda84 View Post
      BTW, I'm now wondering how to set resolution when KMS is enabled. "vga=value" doesn't seem to apply to KMS too, so even after googling I'm left in the dark.
      vga starts vesafb. Iirc video is the right param.

      Comment


      • #4
        Originally posted by nanonyme View Post
        vga starts vesafb. Iirc video is the right param.
        Thank you nanonyme, this seems to be a good starting. Thanks to your hint I've found:
        http://www.mjmwired.net/kernel/Docum...eters.txt#2513
        http://www.mjmwired.net/kernel/Docum.../fb/modedb.txt

        KMS drivers seem to be still undocumented (that is about 2.6.30, so Intel driver should already be there). I'll try to search more up-to-date documentation or try blind guesses!

        I'll let you know!

        Comment


        • #5
          I found this folder in the kernel tree, but nothing seems to explain KMS drivers.
          http://git.kernel.org/?p=linux/kerne...8629;hb=master

          Comment


          • #6
            Even more confused now.
            Here I found that radeonfb should be disabled:
            http://www.x.org/wiki/radeonBuildHow...156363a0d543bc
            Here they suggest to pass video=radeonfb:blahblah
            https://bugs.launchpad.net/ubuntu/+s...63/comments/14

            I'll give it a try...

            Comment


            • #7
              For those interested, the answer to my question is: not yet.
              From today's IRC:
              [17:02] <panda84> sorry if I ask again: is there a way to set default KMS resolution? 1920x1440 is a too high default for my monitor
              [17:03] <AStorm> hmm, maybe video=radeondrmfb:<mode> line?
              [17:03] <agd5f> panda84: not for the console yet

              Comment


              • #8
                Originally posted by panda84 View Post
                Even more confused now.
                Here I found that radeonfb should be disabled:
                http://www.x.org/wiki/radeonBuildHow...156363a0d543bc
                Here they suggest to pass video=radeonfb:blahblah
                https://bugs.launchpad.net/ubuntu/+s...63/comments/14

                I'll give it a try...
                radeonfb doesn't work with KMS so you have to disable kms if you want to use radeonfb.

                Comment


                • #9
                  Originally posted by suokko View Post
                  radeonfb doesn't work with KMS so you have to disable kms if you want to use radeonfb.
                  Right, that's why the string suggested in Ubuntu Launchpad sounded strange to me:
                  Code:
                  radeon.modeset=1 video=radeonfb:1280x1024-24@60
                  Infact it doesn't work.

                  It should be (I think) either:
                  Code:
                  radeon.modeset=0 video=radeonfb:1280x1024-24@60
                  or:
                  Code:
                  radeon.modeset=1
                  which in Fedora is the same as no additional kernel option (KMS enabled by default).

                  Comment


                  • #10
                    There's not currently a way to force an console fb mode with kms. The problem is the kernel fb interface doesn't really have the concept of multiple monitors, so if you want to force a mode, which monitor do you force it on, etc.

                    Comment

                    Working...
                    X