Announcement

Collapse
No announcement yet.

Xv on R600

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xv on R600

    I have Radeon HD2600 card, and ive instaled xf86-video-ati 6.12.2, ati-dri 7.4.2, mesa 7.4.2, kernel 2.6.29.4.

    Unfortunately i cannot get Xv video
    Code:
    X-Video Extension version 2.2
    screen #0
     no adaptors present
    In X log i get error:
    Code:
    └─[$]> cat /var/log/Xorg.0.log | grep EE
    Current Operating System: Linux dinth-archlinux 2.6.29-ARCH #1 SMP PREEMPT Wed May 20 07:06:02 UTC 2009 i686
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) Failed to load module "freetype" (module does not exist, 0)
    (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
    (EE) RADEON(0): Acceleration initialization failed
    It is possible get Xv video now, without using svn builds on R600 card ?

  • #2
    Originally posted by Dinth View Post
    It is possible get Xv video now, without using svn builds on R600 card ?
    To my knowledge, no it is not. As I recall, it's actually the kernel DRM that is in the way. I've personally been using the r6xx-67xx-support branch for a while, though hopefully that will end soon. (Maybe as soon as next week? I've not been following things too close of late.)

    Comment


    • #3
      You need drm update or kernel 2.6.30.

      Comment


      • #4
        what is Ubuntu Jaunty using?

        Comment


        • #5
          He is using Arch-Linux.

          @Dinth: Install a package from AUR: http://aur.archlinux.org/packages.php?ID=24235 . This package build new drm kernel modules without overwriting the old ones.
          And you have to enable EXA and DRI in the xorg.conf.

          Comment


          • #6
            He is using Arch-Linux.

            @Dinth: Install this package from AUR: http://aur.archlinux.org/packages.php?ID=24235 . This package build new kernel modules without overwriting the old ones.
            And you have to enable EXA and DRI in the xorg.conf.

            Comment


            • #7
              Thanks very much i will test it. Must i add something to rc.conf for this ?

              Comment


              • #8
                Originally posted by Dinth View Post
                Thanks very much i will test it. Must i add something to rc.conf for this ?
                No, it installs the modules in the updates folder. They will automatically be used. If you want to use the old modules remove the package.

                Comment


                • #9
                  Originally posted by Perry3D View Post
                  No, it installs the modules in the updates folder. They will automatically be used. If you want to use the old modules remove the package.
                  I finally get Xv to work. Unfortunately, desktop effects in KDE4 still dont work (i have DRI enabled in xorg.conf)

                  Code:
                  (II) AIGLX: Screen 0 is not DRI2 capable
                  drmOpenDevice: node name is /dev/dri/card0
                  drmOpenDevice: open result is 10, (OK)
                  drmOpenByBusid: Searching for BusID pci:0000:01:00.0
                  drmOpenDevice: node name is /dev/dri/card0
                  drmOpenDevice: open result is 10, (OK)
                  drmOpenByBusid: drmOpenMinor returns 10
                  drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
                  (EE) AIGLX error: Calling driver entry point failed(EE) AIGLX: reverting to software rendering
                  Last edited by Dinth; 06-07-2009, 09:06 AM.

                  Comment


                  • #10
                    r600 cards do not have 3D acceleration with the open source drivers, at least not in any form usable for end-users.

                    Adam

                    Comment


                    • #11
                      Originally posted by Dinth View Post
                      I finally get Xv to work. Unfortunately, desktop effects in KDE4 still dont work (i have DRI enabled in xorg.conf)
                      KDE has the ability to enable desktop effects using XRender (which is supported via EXA) rather than OpenGL (which is not supported yet). Maybe give that a try ?

                      Comment


                      • #12
                        Originally posted by bridgman View Post
                        KDE has the ability to enable desktop effects using XRender (which is supported via EXA) rather than OpenGL (which is not supported yet). Maybe give that a try ?
                        I heard it only does a limited set of the actual effects. It should give compositing though.

                        Comment


                        • #13
                          Unfortunately i cannot also enable compositing via Xrender.
                          When i run systemsettings via konsole, i get warning when im entering compositing settings:
                          Code:
                          unknown chip id 0x9589, can't guess.

                          Comment


                          • #14
                            Originally posted by Dinth View Post
                            Unfortunately i cannot also enable compositing via Xrender.
                            When i run systemsettings via konsole, i get warning when im entering compositing settings:
                            Code:
                            unknown chip id 0x9589, can't guess.
                            Try installing xf86-video-ati-git. Maybe your card was already added.

                            Comment


                            • #15
                              I've installed xf-video-ati-git, but something bad happened.
                              Now i have
                              Code:
                              └─[$]> cat /var/log/Xorg.0.log | grep EE
                              Current Operating System: Linux dinth-archlinux 2.6.29-ARCH #1 SMP PREEMPT Wed May 20 07:06:02 UTC 2009 i686
                                      (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
                              (II) Loading extension MIT-SCREEN-SAVER
                              (EE) Failed to load module "freetype" (module does not exist, 0)
                              (EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/r600_dri.so failed (/usr/lib/xorg/modules/dri/r600_dri.so: cannot open shared object file: No such file or directory)
                              (EE) AIGLX: reverting to software rendering
                              in logs.

                              Comment

                              Working...
                              X