Announcement

Collapse
No announcement yet.

Xv on R600

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    That's to be expected, it doesn't have a Mesa driver yet. Ignore that, please.

    Comment


    • #17
      Yep, that's a Good Error (for today, anyways )

      Comment


      • #18
        But unfortunately desktop effects still cannot be enabled. This time without even warning.
        Please tell my what information should i provide.

        Comment


        • #19
          Were you able to go into the "Advanced" screen and select XRender ?

          I think the sequence is "click on Enable Effects => click on Advanced => choose XRender" or something like that...

          EDIT - found some instructions that might help :

          http://kubuntuforums.net/forums/inde...opic=3099721.0

          Comment


          • #20
            When compiling mesa, you can specify r600

            But, the package that I get sticks r600 in /usr/lib/dri. So you can put a link to /usr/lib/dri in /usr/lib/xorg/modules/dri.

            But then I still get dri disabled. I imagine the software is just not ready yet or I'm goofing it up. This for a HD3200. Your results may differ.

            Comment


            • #21
              Yeah, ive tried choosing Xrender. I get KDE warning which tells me that KDE couldnt start desktop effects, and i should check my xorg.conf

              Here is my xorg.conf:
              http://pastebin.com/f521eee95

              and here is my xorg log
              http://pastebin.com/f5b3d626

              Comment


              • #22
                Originally posted by forum1793 View Post
                When compiling mesa, you can specify r600

                But, the package that I get sticks r600 in /usr/lib/dri. So you can put a link to /usr/lib/dri in /usr/lib/xorg/modules/dri.

                But then I still get dri disabled. I imagine the software is just not ready yet or I'm goofing it up. This for a HD3200. Your results may differ.
                Simple answer: the software is not ready yet. You're talking of OpenGL support, it's completely irrelated with EXA+Xv support and doesn't work yet.
                (also the path it put the driver in is correct on a 32bit system)

                Comment


                • #23
                  Originally posted by Dinth View Post
                  Yeah, ive tried choosing Xrender. I get KDE warning which tells me that KDE couldnt start desktop effects, and i should check my xorg.conf.
                  I don't see anything obviously wrong in your log file. Maybe do some pruning on your conf file -- keep :

                  Option "AccelMethod" "EXA"

                  keep the EDID over-rides if you need them :

                  Option "IgnoreEDID" "on"
                  Option "NoDDC" "on"

                  ... and comment out the rest :

                  VideoRam 262144
                  Option "RenderAccel" "on"
                  Option "EnablePageFlip" "on"
                  Option "DRI" "on"
                  Option "ColorTiling" "on"
                  Option "EXAVSync" "on"
                  Option "XAANoOffscreenPixmaps" "true"

                  EXAVSync is supported by the driver but try commenting that out as well just in case... once you get XRender-based desktop effects working you can try turning it back on again.

                  Comment

                  Working...
                  X