Announcement

Collapse
No announcement yet.

Xv on R600

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Dinth View Post
    I finally get Xv to work. Unfortunately, desktop effects in KDE4 still dont work (i have DRI enabled in xorg.conf)
    KDE has the ability to enable desktop effects using XRender (which is supported via EXA) rather than OpenGL (which is not supported yet). Maybe give that a try ?

    Comment


    • #12
      Originally posted by bridgman View Post
      KDE has the ability to enable desktop effects using XRender (which is supported via EXA) rather than OpenGL (which is not supported yet). Maybe give that a try ?
      I heard it only does a limited set of the actual effects. It should give compositing though.

      Comment


      • #13
        Unfortunately i cannot also enable compositing via Xrender.
        When i run systemsettings via konsole, i get warning when im entering compositing settings:
        Code:
        unknown chip id 0x9589, can't guess.

        Comment


        • #14
          Originally posted by Dinth View Post
          Unfortunately i cannot also enable compositing via Xrender.
          When i run systemsettings via konsole, i get warning when im entering compositing settings:
          Code:
          unknown chip id 0x9589, can't guess.
          Try installing xf86-video-ati-git. Maybe your card was already added.

          Comment


          • #15
            I've installed xf-video-ati-git, but something bad happened.
            Now i have
            Code:
            └─[$]> cat /var/log/Xorg.0.log | grep EE
            Current Operating System: Linux dinth-archlinux 2.6.29-ARCH #1 SMP PREEMPT Wed May 20 07:06:02 UTC 2009 i686
                    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
            (II) Loading extension MIT-SCREEN-SAVER
            (EE) Failed to load module "freetype" (module does not exist, 0)
            (EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/r600_dri.so failed (/usr/lib/xorg/modules/dri/r600_dri.so: cannot open shared object file: No such file or directory)
            (EE) AIGLX: reverting to software rendering
            in logs.

            Comment


            • #16
              That's to be expected, it doesn't have a Mesa driver yet. Ignore that, please.

              Comment


              • #17
                Yep, that's a Good Error (for today, anyways )

                Comment


                • #18
                  But unfortunately desktop effects still cannot be enabled. This time without even warning.
                  Please tell my what information should i provide.

                  Comment


                  • #19
                    Were you able to go into the "Advanced" screen and select XRender ?

                    I think the sequence is "click on Enable Effects => click on Advanced => choose XRender" or something like that...

                    EDIT - found some instructions that might help :

                    http://kubuntuforums.net/forums/inde...opic=3099721.0

                    Comment


                    • #20
                      When compiling mesa, you can specify r600

                      But, the package that I get sticks r600 in /usr/lib/dri. So you can put a link to /usr/lib/dri in /usr/lib/xorg/modules/dri.

                      But then I still get dri disabled. I imagine the software is just not ready yet or I'm goofing it up. This for a HD3200. Your results may differ.

                      Comment

                      Working...
                      X