Announcement

Collapse
No announcement yet.

Testing radeon KMS on Ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    I think KMS and GEM/TTM for radeon went into 2.6.31, not 2.6.30...

    Comment


    • #47
      yeah maybe the update is unpatched kernel from main ubuntu repos ?

      I mean the last listed kernel here :
      https://launchpad.net/~xorg-edgers/+archive/radeon-kms
      is
      linux - 2.6.30-9.10kms6 uploaded 2009-06-17

      you should obviously stick to that if you want KMS

      Comment


      • #48
        Originally posted by tormod View Post
        Sounds like you did not copy the live CD correctly and you have some conflicts with old live CD stuff on it.

        1. Make sure you delete the old casper folder on the stick
        2. Use usb-creator instead of whatever scripts
        I had 2 other partitions with live CD isos on them. Apparently the init script doesn't just use the partition it booted from, it searches for a /casper directory on every block device it can mount. Seems a bit strange, because my other two isos boot just fine without any confusion. Anyway, I renamed the /casper on the other two partitions so they wouldn't be found, so it mounted the correct one from /dev/sdb3.

        Usually I just have to toggle the bootable flag on the partition I want, using fdisk. This new casper script seems like a step backward.

        Anyway, that seemed to be the only problem and so it booted successfully on my Asus M6Ne with Mobility 9700 (M300). But it only sees the LVDS and VGA, it doesn't see my S-Video connector. I guess I'm going to stick with Jaunty for a while longer.

        Comment


        • #49
          Originally posted by highlandsun View Post
          I had 2 other partitions with live CD isos on them. Apparently the init script doesn't just use the partition it booted from, it searches for a /casper directory on every block device it can mount. Seems a bit strange, because my other two isos boot just fine without any confusion. Anyway, I renamed the /casper on the other two partitions so they wouldn't be found, so it mounted the correct one from /dev/sdb3.

          Usually I just have to toggle the bootable flag on the partition I want, using fdisk. This new casper script seems like a step backward.
          casper never looked for a bootable flag. Only the DOS MBR uses the bootable flag AFAIK. casper should verify the .disk/casper-uuid on the block device (against its conf/uuid in the initrd) to make sure it does not mount a wrong /casper directory. Did you boot with the ignore_uuid option?

          Anyway, that seemed to be the only problem and so it booted successfully on my Asus M6Ne with Mobility 9700 (M300). But it only sees the LVDS and VGA, it doesn't see my S-Video connector. I guess I'm going to stick with Jaunty for a while longer.
          You can always report the bug to help getting it fixed, if it is not a known issue.

          Comment


          • #50
            Originally posted by tormod View Post
            casper never looked for a bootable flag. Only the DOS MBR uses the bootable flag AFAIK. casper should verify the .disk/casper-uuid on the block device (against its conf/uuid in the initrd) to make sure it does not mount a wrong /casper directory. Did you boot with the ignore_uuid option?
            I didn't set any options at all. I dunno why it didn't match UUIDs properly.

            You can always report the bug to help getting it fixed, if it is not a known issue.
            Which bug tracker? That iso is already 2 weeks old, not even sure if the bug is current any more.

            Comment


            • #51
              Originally posted by highlandsun View Post
              I didn't set any options at all. I dunno why it didn't match UUIDs properly.
              Yes, that is strange. Possibly a bug.
              Which bug tracker? That iso is already 2 weeks old, not even sure if the bug is current any more.
              Right, and with all the stuff happening now (kms remake in -ati master, kms kernel enabled by default in karmic, assorted 2.6.31 issues) it can be some days before we get to make a new CD iso. I had to resort to vesa last night

              Comment


              • #52
                Hi! I'm sorry for my ignorance, but what does this KMS feature brings for the radeon cards? I assume this will make the open source drivers better yes? I've a X600 ( RV380 GPU I think ) and since ATI have ceased support for this and other cards with their proprietary driver this could bring some joy into my life, maybe there's still hope for this laptop :P. This feature applies to older GPUs like mine, correct?

                Comment


                • #53
                  KMS on its own allows :

                  - faster and more reliable suspend/resume/VT-switch

                  - the ability to run the X server without root privileges (so less likelihood of wedging your system),

                  - a single graphics driver that is used everywhere. The pre-KMS environment has a variety of different drivers taking turns controlling the hardware, which frequently works well but sometimes doesn't -- suing a single driver for everything also means bootup can be smoother and kernel errors can display messages reliably

                  Equally important to you is that KMS is built on top of a common in-kernel memory manager for graphics (GEM/TTM), which is the pre-requisite for a number of other desireable features :

                  - DRI2 / Redirected Direct Rendering (flicker-free compositing of 3D windows)

                  - higher levels of GL support in the 3D drivers (allows apps/games run which could not run before, allows some already running games to take faster code paths)

                  - Gallium3D (think of it as a new, improved hardware driver model inside Mesa), which offers both higher potential performance and a framework capable of supporting other acceleration APIs including video decode
                  Last edited by bridgman; 07-05-2009, 03:21 PM.

                  Comment


                  • #54
                    Thank you for the info. I hope this get done soon, I've had problems with resume in the past, and well, the current open-source driver lacks power when it comes to games. Good luck for the developers ( even though they might not be reading this :P ).

                    Comment


                    • #55
                      Anyone expreriences random small freezes with kms? This is on a ATI Mobility Radeon X2300

                      Comment


                      • #56
                        Originally posted by PapadakosPanagiotis View Post
                        Anyone expreriences random small freezes with kms? This is on a ATI Mobility Radeon X2300
                        This is probably due to buffer migrations. The new mm code isn't well tuned yet.

                        Comment


                        • #57
                          I'm trying to get kms with latest karmic kernel and using ppa repo from this post, but i think that is not working because on dmesg i have these lines:
                          Code:
                          [   13.118824] [drm] radeon default to kernel modesetting DISABLED.
                          [   13.119111] [drm] Initialized radeon 1.30.0 20080528 for 0000:01:00.0 on minor 0

                          Comment


                          • #58
                            Originally posted by Fenix-TX View Post
                            I'm trying to get kms with latest karmic kernel and using ppa repo from this post, but i think that is not working because on dmesg i have these lines:
                            Code:
                            [   13.118824] [drm] radeon default to kernel modesetting DISABLED.
                            [   13.119111] [drm] Initialized radeon 1.30.0 20080528 for 0000:01:00.0 on minor 0
                            read the comment on the PPA page

                            Comment


                            • #59
                              I'm trying to boot the latest 0.16 livecd hosted on your link on a machine with an agp x1950pro.
                              I'm getting a 'Failed to initalize radeon. Disabling IOCTL' error during the boot process and the system stops.
                              Post #2 says add 'radeon.agpmode=-1' in the kernel command line and ppa says(?) 'radeon.modeset=1'
                              I assume this is where I'm going wrong trying to boot the live system, pushing f6 when the cd first boots and adding 'radeon.modeset=1' etc returns an unknown option error as you boot - and I don't know how to continue.

                              Comment


                              • #60
                                Boot with radeon.modeset=1 to use KMS and with radeon.modeset=0 to run without. Official Ubuntu kernels currently default to 0, the xorg-edgers kernels default to 1.

                                If you have an AGP card, you can force the AGP mode with radeon.agpmode=X where X is 1,2,4,8 (same as the old AGPMode option in xorg.conf, see "man radeon"). You can turn off AGP (and force PCI instead) with radeon.agpmode=-1.

                                "modinfo radeon" lists all options for the radeon module. For general boot options, see https://help.ubuntu.com/community/BootOptions

                                Ignore the "unknown option" warning, it is a false warning.
                                Last edited by tormod; 07-20-2009, 04:54 AM. Reason: "unknown option"

                                Comment

                                Working...
                                X