Announcement

Collapse
No announcement yet.

Testing radeon KMS on Ubuntu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Testing radeon KMS on Ubuntu

    We have set up a package repository at https://launchpad.net/~xorg-edgers/+archive/radeon-kms which has kernel, libdrm, mesa and -ati packages for testing kernel mode-setting (and GEM/TTM/DRI2) on Ubuntu Karmic. The packages might install on Jaunty as well.

    The above page also links to a Karmic-based live CD image (URL might change) which has all bits installed and simply boots up to the wonderful world of KMS...

    Warning: This is experimental code so do not install it on your production system or anywhere where you have valuable data.
    Last edited by tormod; 06-07-2009, 10:00 AM. Reason: warning

  • #2
    Be sure to have radeon.agpmode=-1 set in the kernel command line if you want to read anything. It would be rather annoying if I stated why.

    Comment


    • #3
      Hello,
      first of all I want to ask you if there is KMS support for an Ati Radeon x500 video card. (because this card is kinda old)
      Secondly, I added the 2 entries in sources.list
      But when I run apt-get update and the upgrade I don't see the kernel being upgraded and so this whole thing does not work. I am on Ubuntu 9.04
      Thanks

      Comment


      • #4
        Originally posted by samentu View Post
        Hello,
        first of all I want to ask you if there is KMS support for an Ati Radeon x500 video card. (because this card is kinda old)
        I am not sure there is an X500 model but there is the rv370-based X550. I have tested this on X700 which is not much newer.
        Secondly, I added the 2 entries in sources.list
        But when I run apt-get update and the upgrade I don't see the kernel being upgraded and so this whole thing does not work. I am on Ubuntu 9.04
        Thanks
        True, the kernel in the PPA does not replace the Jaunty kernel but installs side by side (which is good). Therefore you have to run:
        Code:
        apt-get install linux-image-2.6.30-8-generic

        Comment


        • #5
          Originally posted by Neo_The_User View Post
          Be sure to have radeon.agpmode=-1 set in the kernel command line if you want to read anything. It would be rather annoying if I stated why.
          I would not be terribly annoyed if you used a sentence on saying why instead of saying that you won't. I reckon AGP mode is broken on KMS and agpmode=-1 forces PCI mode?

          Comment


          • #6
            Just upgraded to karmic and installed all your packages from ppa regarding kms.
            But I have issues when resuming from suspend. And where do I add radeon.agpmode=-1? When booting the kernel? Should I append that line in the grub menu? Because I already did that and it says unknown option or something like that.
            I did notice the VT's having my monitor's native resolution. That is great But the suspend problem is really an issue

            Comment


            • #7
              Originally posted by samentu View Post
              Just upgraded to karmic and installed all your packages from ppa regarding kms.
              But I have issues when resuming from suspend. And where do I add radeon.agpmode=-1? When booting the kernel? Should I append that line in the grub menu? Because I already did that and it says unknown option or something like that.
              I did notice the VT's having my monitor's native resolution. That is great But the suspend problem is really an issue
              My suspend is broken with the non-kms 2.6.30 kernel as well, so it is not necessarily the fault of KMS in my case. Did you test plain Karmic before installing the KMS crack?

              You can add radeon.agpmode=-1 to the "kernel" line in the grub menu, or for a more permanent setting:
              Code:
              echo "options radeon agpmode=-1" | tee sudo /etc/modprobe.d/radeon-kms.conf
              Then just delete /etc/modprobe.d/radeon-kms.conf once the AGP issues have been fixed.

              Comment


              • #8
                I tried the liveCD with an ATI Technologies Inc M56GL [Mobility FireGL V5250] which worked.
                Then I tried to install the karmic packages on my jaunty installation. This did not work.
                It loads VESA as default and if I force radeon via xorg.conf, it gives me:

                kernel message:
                Code:
                Jun  7 13:25:19 deepblue kernel: [  270.932079] [drm:radeon_fence_wait] *ERROR* fence(f646f680:0x00000002) 504ms timeout going to reset GPU
                Jun  7 13:25:19 deepblue kernel: [  270.933495] [drm] CP reset succeed (RBBM_STATUS=0x10000140)
                Jun  7 13:25:19 deepblue kernel: [  270.933503] [drm] radeon: cp idle (0x10000000)
                Jun  7 13:25:19 deepblue kernel: [  270.933513] [drm] Loading R500 Microcode
                Jun  7 13:25:19 deepblue kernel: [  270.933559] [drm] radeon: ring at 0x0000000010000000
                Jun  7 13:25:19 deepblue kernel: [  271.519871] [drm:radeon_ring_test] *ERROR* radeon: ring test failed (sracth(0x15E4)=0xCAFEDEAD)
                Jun  7 13:25:19 deepblue kernel: [  271.519877] [drm:r100_cp_init] *ERROR* radeon: cp isn't working (-22).
                Jun  7 13:25:19 deepblue kernel: [  271.519885] [drm:rv515_gpu_reset] *ERROR* Failed to reset GPU (RBBM_STATUS=0x90010140)
                Jun  7 13:25:19 deepblue kernel: [  271.519895] [drm:radeon_fence_wait] *ERROR* fence(f646f680:0x00000002) 1096ms timeout
                Jun  7 13:25:19 deepblue kernel: [  271.519900] [drm:radeon_fence_wait] *ERROR* last signaled fence(0x00000002)
                Jun  7 13:25:19 deepblue kernel: [  271.522087] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:19 deepblue kernel: [  271.522094] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:20 deepblue kernel: [  271.870676] [drm:radeon_bo_move] *ERROR* CP is not ready use memcpy.
                Jun  7 13:25:20 deepblue kernel: [  271.876124] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:20 deepblue kernel: [  271.876127] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:21 deepblue kernel: [  272.741028] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:21 deepblue kernel: [  272.741036] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:21 deepblue kernel: [  273.330923] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:21 deepblue kernel: [  273.330929] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:21 deepblue kernel: [  273.444620] [drm:radeon_bo_move] *ERROR* CP is not ready use memcpy.
                Jun  7 13:25:21 deepblue kernel: [  273.463984] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:21 deepblue kernel: [  273.463989] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:21 deepblue kernel: [  273.481191] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:21 deepblue kernel: [  273.481197] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:21 deepblue kernel: [  273.526445] [drm:radeon_bo_move] *ERROR* CP is not ready use memcpy.
                Jun  7 13:25:21 deepblue kernel: [  273.526580] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:21 deepblue kernel: [  273.526583] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:21 deepblue kernel: [  273.526688] [drm:radeon_bo_move] *ERROR* CP is not ready use memcpy.
                Jun  7 13:25:21 deepblue kernel: [  273.526716] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(0).
                Jun  7 13:25:21 deepblue kernel: [  273.526718] [drm:radeon_cs_ioctl] *ERROR* Faild to schedule IB !
                Jun  7 13:25:21 deepblue kernel: [  273.527003] [drm:radeon_bo_move] *ERROR* CP is not ready use memcpy.
                xorg.log:
                Code:
                CS failure ...corruption... -22
                while it still draws something, it is unbearable slow. It takes several seconds to just refresh the screen.

                is perhaps something misconfigured missing? Id like to use DRI2, but I want to stick with jaunty.

                edit:
                just tried to wake up from suspend from the liveCD. It basically worked, but the radeon driver failed with the same message as when booting jaunty.
                Last edited by madman2k; 06-07-2009, 08:03 AM.

                Comment


                • #9
                  Thanks for the quick replies.
                  I did not tested Karmic before installing the KMS kernel. My bad
                  I created the radeon-kms.conf file but I see no change. So I don't know what this should fix
                  And another thing ... do you guys have plymouth packages for karmic in ppa?

                  Comment


                  • #10
                    Resuming from suspend I get: [drm:radeon_bo_move] *ERROR* CP is not ready use memcpy.
                    If I switch back and forth with CTRL_ALT+F1 and CTRL+ALT+F7 I manage to get the password prompt but on enter nothing happens. So I go back to VT1 and then back to X and I am loggen in but still can't see nothing but window borders and a lot of white and grey. And going back and forth again displays a new program if you managed to start one blindly from a terminal and so on.
                    And at about this time I get a lot of "*ERROR* Failed to schedule IB !"

                    All this only on resume.

                    Comment


                    • #11
                      Originally posted by madman2k View Post
                      Then I tried to install the karmic packages on my jaunty installation. This did not work.
                      It loads VESA as default
                      So you did not read the note on the PPA page, obviously.
                      and if I force radeon via xorg.conf, it gives me:
                      Are you actually booting the kernel from the PPA?

                      Comment


                      • #12
                        Originally posted by samentu View Post
                        Thanks for the quick replies.
                        I did not tested Karmic before installing the KMS kernel. My bad
                        I created the radeon-kms.conf file but I see no change. So I don't know what this should fix
                        It should turn off AGP mode (and use PCI mode instead) on AGP cards. But you have a PCI-E card, right?
                        And another thing ... do you guys have plymouth packages for karmic in ppa?
                        The plan for Karmic is to not use plymouth nor usplash, but rather make the boot so fast that you would not care

                        There is a PPA somewhere with plymouth packages IIRC. Search for it.

                        Comment


                        • #13
                          I added a warning to the original post. For instance, if you are sticking to Jaunty for some reason, maybe you should not install these packages for the same reason.

                          I can confirm that both suspend and hibernation is broken, but I am not sure if it is KMS or another kernel problem. I even had bits of my .bash_history and firefox profile ending up in /var/log/syslog so there is apparently the possibility of major file (system) corruption.

                          Comment


                          • #14
                            Originally posted by tormod View Post
                            So you did not read the note on the PPA page, obviously.
                            nope, but I figured out myself

                            Are you actually booting the kernel from the PPA?
                            yup I do - Im getting high res console and usplash gets kicked out. probably something is not getting initialized properly - something that should have been also re-initialzed on wakeup from suspend.

                            Comment


                            • #15
                              Originally posted by tormod View Post
                              It should turn off AGP mode (and use PCI mode instead) on AGP cards. But you have a PCI-E card, right?

                              The plan for Karmic is to not use plymouth nor usplash, but rather make the boot so fast that you would not care

                              There is a PPA somewhere with plymouth packages IIRC. Search for it.
                              Yes, indeed I have a PCI-Express card.
                              I've read about the boot in under 10 seconds for karmic ... I just hope they do that for this next release.
                              Thanks again

                              Comment

                              Working...
                              X