Announcement

Collapse
No announcement yet.

radeonhd r6xx-7xx EXA performance patch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Obscene_CNN View Post
    tball


    Are you in the xf86-video-radeonhd directory when you issue the patch command?
    Yes. But nevermind. It worked with the diff/patch tool in kde.


    Code:
    Sustem:
    2.6.29-ARCH Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
    HD 3650 mobility
    
    Test rounds: 1000
    Driver: RadeonHD-git
    Total time: 66,67
    
    Test rounds: 1000
    Driver: RadeonHD-git with patch
    Total time: 62,07
    
    Test rounds: 1000
    Driver: Radeon-git
    Total time: 65,43 
    
    BUT
    Test rounds: 1000
    Driver: Fglrx
    Total time: 185,38
    How can fglrx be so much slower. The lack of EXA support?
    Last edited by tball; 05-23-2009, 08:37 AM.

    Comment


    • #32
      Ah its a DOS CR/LF text file that gets downloaded.....

      we can fix it
      try the commands

      sed 's/.$//' patch > fixed.patch

      patch -p1 < fixed.patch

      Comment


      • #33
        oops, too late. thanks for testing.

        edit looks like a 7% improvement
        Last edited by Obscene_CNN; 05-22-2009, 02:05 PM.

        Comment


        • #34
          Originally posted by Obscene_CNN View Post
          Ah its a DOS CR/LF text file that gets downloaded.....

          we can fix it
          try the commands

          sed 's/.$//' patch > fixed.patch

          patch -p1 < fixed.patch
          There is a tool called dos2unix. Easy and quick.

          Comment


          • #35
            Originally posted by tball View Post
            How can fglrx be so much slower. The lack of EXA support?
            Is it possible that fglrx.ko (from /lib...) is not loaded but xorg uses the fglrx.drv located at /usr...? This might be a VESA fallback if fglrx.ko not loaded but xorg.conf still requires it. Does lsmod | grep fglrx show its loaded?

            Comment


            • #36
              Originally posted by forum1793 View Post
              Is it possible that fglrx.ko (from /lib...) is not loaded but xorg uses the fglrx.drv located at /usr...? This might be a VESA fallback if fglrx.ko not loaded but xorg.conf still requires it. Does lsmod | grep fglrx show its loaded?
              I don't think vesa runs kwin composite very well

              fglrx.ko is loaded alright and I didn't use composite when running gtkperf.

              Comment


              • #37
                I have updated the patch for a little more speed.

                download it from here http://pastebin.com/f781ff0f and save it as a file.

                Then run dos2unix on it.

                It then should be able to be applied to current git or radeonhd-1.2.5

                Comment


                • #38
                  Yet more speed

                  Download the latest patch here

                  http://pastebin.com/ff1e8c3c

                  Note when downloading from this link it will down load as a dos text file with a CR/LF at the end of every line.

                  we can fix it with the command

                  sed 's/.$//' patch > fixed.patch

                  or run dos2unix on the patch file.

                  once again it should be able to be applied to current git or radeonhd-1.2.5

                  Comment


                  • #39
                    Originally posted by Obscene_CNN View Post
                    Yet more speed

                    Download the latest patch here

                    http://pastebin.com/ff1e8c3c

                    Note when downloading from this link it will down load as a dos text file with a CR/LF at the end of every line.

                    we can fix it with the command

                    sed 's/.$//' patch > fixed.patch

                    or run dos2unix on the patch file.

                    once again it should be able to be applied to current git or radeonhd-1.2.5
                    Can You explain how the patch is applied... Sorry for dumb question but I do not want to mess what need not to be messed ...

                    Comment


                    • #40
                      zika,

                      okay.

                      First make sure you can build and install the sources as shown here

                      http://www.x.org/wiki/radeonhd

                      Next make sure you have acceleration working.

                      Next, download the patch from this location and save it as the filename 'patch' in your xf86-video-radeonhd directory.

                      http://pastebin.com/ff1e8c3c

                      now you have 2 options.

                      From the xf86-video-radeonhd directory type the command
                      dos2unix -n patch fixed.patch

                      Or

                      From the xf86-video-radeonhd directory type the command
                      sed 's/.$//' patch > fixed.patch


                      finally from the xf86-video-radeonhd issue the command
                      patch -p1 < fixed.patch


                      I hope this helps

                      Edit:
                      Note you can remove the patch with this command if it causes trouble
                      patch -p1 -R < fixed.patch
                      Last edited by Obscene_CNN; 05-27-2009, 10:55 AM.

                      Comment


                      • #41
                        Originally posted by Obscene_CNN View Post
                        zika,

                        okay.

                        First make sure you can build and install the sources as shown here

                        http://www.x.org/wiki/radeonhd

                        Next make sure you have acceleration working.

                        Next, download the patch from this location and save it as the filename 'patch' in your xf86-video-radeonhd directory.

                        http://pastebin.com/ff1e8c3c

                        now you have 2 options.

                        From the xf86-video-radeonhd directory type the command
                        dos2unix -n patch fixed.patch

                        Or

                        From the xf86-video-radeonhd directory type the command
                        sed 's/.$//' patch > fixed.patch


                        finally from the xf86-video-radeonhd issue the command
                        patch -p1 < fixed.patch


                        I hope this helps

                        Edit:
                        Note you can remove the patch with this command if it causes trouble
                        patch -p1 -R < fixed.patch
                        Thank You. The problem is that I've installed radeon{,hd} and drm in some another way, through ppa's and, lately, with easy-drm-modules-installer, so I do not have xf86-video-radeonhd directory ... I will investigate the situation more, I'm up-to date to tormod, pendretti, xorg-crack and radeon-rewrite (with both radeon{,hd}) ...
                        Thank You,again ...

                        Comment


                        • #42
                          gtkperf doesn't seem very consistent, I ran the test a few times at x1000 with your latest patch. These are the results
                          1 Total time: 103.18
                          2 Total time: 104.41
                          3 Total time: 105.26
                          4 Total time: 99.90

                          On the fourth run I moved the mouse cursor between the screens (dualhead)

                          Same with x100 if I move the mouse cursor to the other monitor there's a 1 second diffrence between the results.

                          Comment


                          • #43
                            You should set your cpu to performance mode, otherwise you bench speedstep/powernow...

                            Comment


                            • #44
                              I got coolnquite disabled in the BIOS.

                              cat /proc/cpuinfo says 2800.242 MHz

                              Comment


                              • #45
                                As I have stated before I'm not a fan of gtkperf.

                                I get my most consistent results when running gkrellm along side it for some strange reason.

                                also to see what freq your cpu is working at at the moment you need to

                                cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq

                                Comment

                                Working...
                                X