Announcement

Collapse
No announcement yet.

3D acceleration on ppc

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3D acceleration on ppc

    What is the state of the radeon driver on ppc machines? I tested Ubuntu 9.04 on a PowerBook G4 with a Mobility 9600 and it didn't seem to have 3D acceleration with the default driver. Have not yet tested the latest from git yet.

  • #2
    Originally posted by glock24 View Post
    What is the state of the radeon driver on ppc machines? I tested Ubuntu 9.04 on a PowerBook G4 with a Mobility 9600 and it didn't seem to have 3D acceleration with the default driver. Have not yet tested the latest from git yet.
    PPC should work, although I think there is an issue with the ubuntu kernel. You might try a vanilla kernel.
    Last edited by agd5f; 05-11-2009, 09:42 PM.

    Comment


    • #3
      Yes, this is a kernel bug, should be fixed in an update soon: https://bugs.launchpad.net/bugs/345542

      Comment


      • #4
        You could try

        http://kanotix.com/files/fix/dkms/dr...upport-dkms.sh

        or

        http://kanotix.com/files/fix/dkms/dr...7xx-3d-dkms.sh

        But not both the same time, remove is like this

        dpkg --purge drm-r6xx-r7xx-support-dkms

        or

        dpkg --purge drm-r6xx-r7xx-3d-dkms

        That only updates the drm modules, kernel version does not matter. If ppc does not compile all modules just change it a little bit. I compile all because i want to be able to switch to other cards too.

        Comment


        • #5
          Well, he has got a Radeon 9600 so he does not need r6xx/r7xx stuff.

          Comment


          • #6
            Well it would not hurt.

            Comment


            • #7
              I'll just compile a 2.6.30 kernel when I have the time and try the 3d acceleration. Thanks for the answers, I'll inform you if the newer kernel solves the problem.

              Comment


              • #8
                Originally posted by glock24 View Post
                I'll just compile a 2.6.30 kernel when I have the time and try the 3d acceleration. Thanks for the answers, I'll inform you if the newer kernel solves the problem.
                You can also install the Karmic 2.6.30 kernels, but as you can see in the above bug report, there are currently some boot issues.

                Comment

                Working...
                X