Announcement

Collapse
No announcement yet.

Xpress 200M problems... again

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Sorry, I forgot about this. You have to install autoconf and satisfy all dependencies for mesa compilation:
    1) sudo apt-get install autoconf;
    2) sudo apt-get build-dep mesa;
    Then try: ./autogen.sh --prefix=/usr. Autoconf will show you any other libraries you need - install them in Synaptic. For example, if you need xt, search for 'xt' and install libxt-dev and so on.

    Comment


    • #17
      did it manually, but works Now I'm compiling new mesa... I hope, it will work. Thanks for your help!

      Comment


      • #18
        Okay.

        Compiled with some errors, installed with some errors. Works, but nothing has changed. Still got 300-330fps in glxgears (got 1200-1300 with fglrx under 8.10)... Maybe I did it wrong?

        Comment


        • #19
          You can not compile with errors. If you have errors your new mesa libraries are not installed. Check your ./mesa-radeon-rewrite/lib directory. You must see a lot of libraries there. During the installation they will replace the old Mesa stuff (for example, in /usr/lib/dri).

          Comment


          • #20
            I feel myself so stupid... Where I have to find ./mesa-radeon-rewrite directory? If where i unpack the tar, then i can only find these in the /mesa-radeon-rewrite/lib:

            i810_dri.so
            libGL.so
            libGL.so.1
            libGL.so.1.2

            nothing else...

            Comment


            • #21
              This means that you have problems with the comilation of the next library. I do not remember the compilation order but it might be i915_dri.so. Please post your error when you do make. I belive that somebody can help you here. I am not a specialist in this.

              Comment


              • #22
                Many times:

                ...leaving directory.
                [error 1]

                I'll try again...

                Comment


                • #23
                  Originally posted by Bobber76 View Post
                  Many times:

                  ...leaving directory.
                  [error 1]

                  I'll try again...
                  Tthe error will be just before these messages

                  Comment


                  • #24
                    Here's the end of 'make':

                    intel_screen.c: In function ‘intel_init_bufmgr’:
                    intel_screen.c:617: error: ‘I915_PARAM_NUM_FENCES_AVAIL’ undeclared (first use in this function)
                    intel_screen.c:617: error: (Each undeclared identifier is reported only once
                    intel_screen.c:617: error: for each function it appears in.)
                    make[5]: *** [intel_screen.o] Error 1
                    make[5]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa/drivers/dri/i915'
                    make[4]: *** [subdirs] Error 1
                    make[4]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa/drivers/dri'
                    make[3]: *** [default] Error 1
                    make[3]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa/drivers'
                    make[2]: *** [driver_subdirs] Error 2
                    make[2]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa'
                    make[1]: *** [subdirs] Error 1
                    make[1]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src'
                    make: *** [default] Error 1

                    Comment


                    • #25
                      Good luck

                      You can try to compile mesa only for ati:
                      ./autogen.sh --prefix=/usr --with-dri-drivers=radeon,r200,r300

                      Comment


                      • #26
                        Originally posted by sergus View Post
                        You can try to compile mesa only for ati:
                        ./autogen.sh --prefix=/usr --with-dri-drivers=radeon,r200,r300
                        You can also disable gallium:
                        ./autogen.sh --prefix=/usr --with-dri-drivers=radeon,r200,r300 --disable-gallium

                        Comment


                        • #27
                          Thanks to both of you!

                          That was worked for me. Now I have the same FPS under jaunty, as with fglrx+Intrepid, and now I have no lockups! Thanks!

                          Comment


                          • #28
                            Hi there

                            I've installed this mesa-radeon-rewrite, but now
                            glxgears:
                            drmRadeonCmdBuffer: -22

                            Comment


                            • #29
                              Originally posted by hugoea View Post
                              Hi there

                              I've installed this mesa-radeon-rewrite, but now
                              glxgears:
                              drmRadeonCmdBuffer: -22
                              The same is for me .

                              Comment


                              • #30
                                Originally posted by rayunix View Post
                                The same is for me .
                                See http://bugs.freedesktop.org/show_bug.cgi?id=21776

                                Comment

                                Working...
                                X